Computer hard drive disk managment

G

Guest

Guest
Hello, I have a hard disk I am unable to view. It's a Toshiba MK3265GSXV hard drive from a Toshiba Satellite C650 laptop. The laptop bluescreened and would not boot up due to not recognising the disk. I have moved the disk to a caddy and I am still unable to view it, which I expected to be honest. I can rebuild the laptop with another disk but I need to retrieve the data from the faulty disk. Can anyone point me in the right direction?
 

electrontau

Distinguished
Dec 1, 2010
669
0
19,160
if you put the drive in an enclosure and was not able to read/detect it, there is a chance the drive is defective. If that is the case, data retrieval is done by some specialized companies. It will be costly.
 
G

Guest

Guest
Thanks Electrontau. I know about that anyway. I was just hoping there might be some tool out there to retrieve the data. The disk does spin but other than that I can't get any response.
 

dg27

Distinguished
Nov 7, 2010
422
11
18,815
I paid for data recovery several years ago and said "never again... ." :eek:

One free option you might try is Recuva:

http://www.piriform.com/recuva/download

Another option might be Zero Assumption Recovery. There's a free version available on CNET here:

http://download.cnet.com/Zero-Assumption-Recovery/3000-2248_4-10061981.html

I own the paid version, which did an outstanding job when I had a disk that I believed was dead in the water. I had thousands of files (mostly travel photos) and recovered everything:

http://www.z-a-recovery.com/digital-image-recovery.htm

Good luck!

dg



 
G

Guest

Guest
Thanks DG. I tried ZAR but it didn't work, which I expected as the drive does not show up in Windows or Drive Manager. Like I said, it does spin but it just doesn't show up in Windows.

I guess it's a lost cause but I just wanted to get the photo's off and hoped there'd be some way to do it given that the disc still spins.
 

atmywitsend

Distinguished
Feb 11, 2012
1
0
18,510
I also have a Toshiba Satellite Pro C650 with the same hdd as Anonymous...... When I start it, the Toshiba logo comes up then I get a black screen with a '_' flashing in the top left corner, then a msg prints..... "Intel UNDI, PXE-2.0 (build 083) Copyright (C) 1997-2000 Intel Corporation For Atheros PCIE Ethernet Controller v2.0.1.9(12/15/09)
Check cable connection! PXE-M0F: Exiting Intel PXE ROM No bootable device -- insert boot disk and press any key"
If I F12 at startup, boot menu - select HDD/SSD, I get the above msg... If I choose <enter setup> there is no HDD/SSD, i then reset defaults - save & exit.... still the same msg.

There were no discs with the laptop when purchased nov '10.
I really would appreciate a solution