• Enter here for a chance to win a custom MechWarrior 5: Mercenaries themed PC powered by Intel!

Question Computer has black screen and loud fan noise ?

Apr 23, 2021
6
0
10
0
So I have built my computer abt 3 years ago, And about after 2 years and 8 months my computer has been doing something very wierd. It first started randomly when I was installing an updated version of my gpu drivers and then the screen went black and said no signal,Im not sure which fan but one of the fans went extremley loud and the screen wouldnt show signal again unless i restarted the computer. The wierd thing was i could still hear my friends in discord and when i pressed my hotkey to defean and undeafen it would work. After I restarted the computer it wouldnt load back into windows unless i reseted the pc or downloaded a new version of windows.We decided to throughly clean the computer taking each component apart and cleaning the insides then it worked again,But it recently has been having the same issues!!

My Hardware is
CPU: Amd Ryzen 1600x
CPU COOLER:Deepcooler
GPU:Geforce GTX 10603gb
Motherboard:Gigabyte B-450
Psu:EVGA 500w
Storage:1tb HD | 500gb SSD
And 16GB hddr ram
 

The Idiot

Distinguished
Apr 4, 2013
107
12
18,595
1
Have you installed any new gpu drivers since this issue? The gpu driver most likely became corrupted during install or with the sudden shut down. You should use a tool like DDU to romove all old gpu drivers. If this issue continues maybe try a different port on the gpu if you have that option. This might be a case where you have to play around with gpu drivers until you find a stable version.
 
Last edited:
Apr 23, 2021
6
0
10
0
Hi yes I have downloaded new gpu drivers and whenever the computer works i download he latest version of drivers,Last night something wierd happened i went to go and try turn on the computer and it wouldnt turn on when i pressed the power button it would flash the led lights and fans then it would stop?
 
Apr 23, 2021
6
0
10
0
Hey so i got my computer on and then i went to go launch gta story mode and my screen turned off and was saying no signal I could still hear audio just the screen saying no signal does this mean it is my gpu?
 

The Idiot

Distinguished
Apr 4, 2013
107
12
18,595
1
Hey so i got my computer on and then i went to go launch gta story mode and my screen turned off and was saying no signal I could still hear audio just the screen saying no signal does this mean it is my gpu?
That is most likely the case. Try to remove the old gpu drivers and see if the issue stops. Does the grinding sound happen every time you lose signal?https://outervision.com/power-supply-calculator use this link enter all your specs and see if your current psu meets the requirements.
 
Last edited:
Apr 23, 2021
6
0
10
0
That is most likely the case. Try to remove the old gpu drivers and see if the issue stops. Does the grinding sound happen every time you lose signal?https://outervision.com/power-supply-calculator use this link enter all your specs and see if your current psu meets the requirements.
Yeah i have well enough power for my computer i went to use the ddr program but it couldnt seem to find or delete any old drivers,a tech savy friend of mine said he thinks it is the psu being worn out
 

ASK THE COMMUNITY