Question Computer has stopped working and freezing on startup

Dec 18, 2021
2
0
10
0
My computer was working fine for a while, but I had recently started it up for the first time in a few months. When I booted it up for the first time everything seemed to be fine, a couple hours later I got a blue screen. The computer would turn on but none of the peripherals would work and the monitor was not recognizing any output. It would eventually turn on, but I would basically turn it on and off until it worked. My VGA light on my motherboard was on, so I tried to reseat my graphics card the light turned off so I thought everything was fine. I went to turn on my computer and now a couple seconds after startup it freezes and my peripherals disconnect. I tried resetting the CMOS, I replaced the battery and tried reinstalling my RAM with no success. I can get it into the BIOS though, and when I do nothing shuts off and it seems to be fine, but when I close it everything freezes again. Any recommendations would be greatly appreciated.

My specs:
Ryzen 7 1700/NZXT Kraken
EVGA GTX 1080 SC
GIGABYTE GA-AX370-Gaming 5
GSKILL 16 GB RAM
 

Ferimer

Distinguished
My computer was working fine for a while, but I had recently started it up for the first time in a few months. When I booted it up for the first time everything seemed to be fine, a couple hours later I got a blue screen. The computer would turn on but none of the peripherals would work and the monitor was not recognizing any output. It would eventually turn on, but I would basically turn it on and off until it worked. My VGA light on my motherboard was on, so I tried to reseat my graphics card the light turned off so I thought everything was fine. I went to turn on my computer and now a couple seconds after startup it freezes and my peripherals disconnect. I tried resetting the CMOS, I replaced the battery and tried reinstalling my RAM with no success. I can get it into the BIOS though, and when I do nothing shuts off and it seems to be fine, but when I close it everything freezes again. Any recommendations would be greatly appreciated.

My specs:
Ryzen 7 1700/NZXT Kraken
EVGA GTX 1080 SC
GIGABYTE GA-AX370-Gaming 5
GSKILL 16 GB RAM
what had happened before as to why you havent turned it on in a few months? was there an issue that happened? I would try completely stripping the computer and re connecting all your components. Have you cleaned it since its been sitting for so long?
 
Dec 18, 2021
2
0
10
0
what had happened before as to why you havent turned it on in a few months? was there an issue that happened? I would try completely stripping the computer and re connecting all your components. Have you cleaned it since its been sitting for so long?
The reason I wasn’t using it was because I was at college and did not bring it. I switched the motherboard with a different one and it seems to have solved the problem. It is not freezing anymore and looks to be fine.
 

ASK THE COMMUNITY