[SOLVED] Computer Infected with "Windows display service" Virus

Jul 26, 2021
35
1
35
0
I was today just working until MalwareBytes blocked "Windows-display-service.com" So I did a scan right away (Since I didn't even have ANY browser open) and it found 2 threats called "Trojan.AgentVBS" I removed them but like 20-30 minutes later the Windows-display-service.com was blocked due to "riskware" notification appeared again
Can someone please PLEASE tell me how to remove this?
 
We'd have to assume your Malwarebytes install was from a legit source, and, that you are correct in your assertions that you did not download something 'sketchy', and, the latter sounds a bit suspect (no offense intended), as Malwarebytes is not really known for alerting to/blocking legit things all that frequently (i.e., false positives). If it was merely a website link or add being blocked, we'd have to assume the block was likely for your own good.

If you think you have actual malware you can check your available restore points, and, perhaps role to a point in time back several days or a week ago, the intent being before you had malware.
 
Jul 26, 2021
35
1
35
0
We'd have to assume your Malwarebytes install was from a legit source, and, that you are correct in your assertions that you did not download something 'sketchy', and, the latter sounds a bit suspect (no offense intended), as Malwarebytes is not really known for alerting to/blocking legit things all that frequently (i.e., false positives). If it was merely a website link or add being blocked, we'd have to assume the block was likely for your own good.

If you think you have actual malware you can check your available restore points, and, perhaps role to a point in time back several days or a week ago, the intent being before you had malware.
i reinstalled windows 3 days ago-
 
When you reinstalled, was it a 'repair install'(i.e, reinstall, but keep my data/files/apps)? (This is rarely sufficient for removing malware, as all of your old data/apps ,of which who knows how many are infected, still remain)
 
Jul 26, 2021
35
1
35
0
When you reinstalled, was it a 'repair install'(i.e, reinstall, but keep my data/files/apps)? (This is rarely sufficient for removing malware, as all of your old data/apps ,of which who knows how many are infected, still remain)
No, I formatted the hard drive before instaling windows.
What was the reason for the recent OS install?
Computer was running really slowly and it was so but SO slow at that point I formatted the whole hard drive and re-installed windows 10.
 
Jul 26, 2021
35
1
35
0
Update:I think i fixed it.?
I ran NPE,HitmanPro A Full scan of MBAM,ADWCleaner and Zemana AntiMalware 3.0
They detected 2 Malicious Registry keys and 3 malicious files
I did that over a week ago and havnt got it again.
Anyways thanks for everyone who helped in this post :)
 

ASK THE COMMUNITY

TRENDING THREADS