Question Computer is turning on (RGB lights and CPU fan turns on) but there is no display and no beep code

Dec 26, 2020
2
0
10
0
I really don’t know if this is considered a no post problem or if it is a problem with the CPU.

So I recently got a a new CPU, motherboard, and ram and was in the process of upgrading it today when I finished installation I went to go boot up, all the lights turned on, even the cpu fan, and but there was no BIOS display, this was also a used motherboard but I had already reset the bios. So the friend I was with tried a lot of stuff, we checked all of the power cables, tried powering up with 5 different video configurations ( on board graphics + GPU ) and even went and got new RAM sticks. But nothing is working. I know that it’s not the CPU cause I installed it correctly (gently with the arrow on the right socket corner) my board supports the cpu, and I just don’t know what the problem is.

Specs :
Radeon RX 570 GPU
AMD Ryzen 5 3600
A320-M HDV - Asrock board
Corsair bronze 750 W fully modular power supply
Corsair vengeance 3600 MHz DDR4 8 gb RAM (two sticks)
 
I really don’t know if this is considered a no post problem or if it is a problem with the CPU.

So I recently got a a new CPU, motherboard, and ram and was in the process of upgrading it today when I finished installation I went to go boot up, all the lights turned on, even the cpu fan, and but there was no BIOS display, this was also a used motherboard but I had already reset the bios. So the friend I was with tried a lot of stuff, we checked all of the power cables, tried powering up with 5 different video configurations ( on board graphics + GPU ) and even went and got new RAM sticks. But nothing is working. I know that it’s not the CPU cause I installed it correctly (gently with the arrow on the right socket corner) my board supports the cpu, and I just don’t know what the problem is.

Specs :
Radeon RX 570 GPU
AMD Ryzen 5 3600
A320-M HDV - Asrock board
Corsair bronze 750 W fully modular power supply
Corsair vengeance 3600 MHz DDR4 8 gb RAM (two sticks)
What about BIOS version, it probably needs to be updated ?
 

ASK THE COMMUNITY

TRENDING THREADS