Question Computer lags on ASROCK splash screen when unplugged or hardware changed, sometimes doesn't start at all.

Brookcie

Distinguished
Nov 8, 2011
26
0
18,540
1
Computer Specs:

CPU: AMD Ryzen 5 2600x six core 3.6GHz
RAM: 16Gb CORSIAR VENGEANCE (2x8Gb)
PSU: Silverstone 500W
GPU: GTX 970 4Gb
Motherboard: AsRock AB350M Pro4
OS: Windows 10

Have had computer for almost 2 years.

Problem Summary:
As recent as under a year ago, when changing hardware or unpugging my computer and reconnecting a few minutes later, the AsRock splash screen with the spinning white circle would go for AGES (like 30 minutes), before finally running the OS and booting up fine. When computer starts and restarts from the OS, there is no long delay at startup. 3 days ago, it booted up (not sure if I changed hardware) and took probably an hour to get past the flash screen. Yesterday I had to hard reset my computer during a normal restart as it froze on a page while restarting, then the computer did NOT even get to the splash screen. The computer would boot, fans spin, no beeps, display does NOT show anything.

Things I have tried to fix:
1) Took all connections out besides CPU and slowly started adding them back. This is where it gets strange, sometimes WITHOUT changing the hardware - the computer would experience different behaviour. For example, it booted with one stick of RAM to the BIOS screen (great!) but then I restarted and then it did NOT do it again and showed no display. It would boot to BIOS with 2 RAM sticks (great!), then I would connect my HDD and it would not boot or show display....then UNPLUG ONLY HDD - and now it doesn't boot up with only the 2 RAM sticks like it did 4 minutes ago.

2) Resit the CMOS - didn't appear to do anything.

3) Tried different SATA port for HDD, managed to get it to start up and that's how I am making this post on the forum. But I think this was a fluke as the SATA port is irrelevant as when no HDD is connected to the SATA ports, the computer doesn't boot sometimes to BIOS but then it DOES boot to BIOS despite the hardware being the same config.


I hope what I am, saying makes sense.

In a nutshell:

Computer didn't boot to BIOS or show display, changing hardware SOMETIMES got it to boot, but then the same hardware config would sometimes NOT boot to BIOS. Somehow managed to get it to boot to AsRock splash screen (waited 45 minutes) and logged onto here and make this forum - have not restarted since.
 

ASK THE COMMUNITY

TRENDING THREADS