Computer/motherboard won't boot or post


Dec 15, 2011
So I have a completely new rig I just put together which are

Motherboard: Asrock z68 pro3
CPU: intel i5-2500k sandy bridge
RAM: G.skill 2x4gb 1333 ddr3 ram
Gpu: his radeon iceq x turbo 6950 2gb
Psu: pc power and cooling silencer mk2 650w

Anyways here's the problem. The computer boots with all the case fans, CPU fan and gpu fan running but there's no video or any beeping. I've tried combinations of everything like disconnecting RAM or the optical and hard drives but still nothing. Only thing I haven't tried is unhooking the gpu from the pci-e 2.0x16 slot because when I try to remove it, it comes out halfway only. The "lock" part is the half with the card still. Pressing it down or to the left right or up doesn't do anything.

Can any kind soul offer help? And please excuse any mistakes since I'm typing this Ina an iPhone.
OK. Firstly, put everything right back in place and make sure that the GPU that you've half pulled out is pushed and locked back in place, make sure that the PCIe GPU power connectors are also plugged in.

Now remove the Monito cable from the GPU and connect it to the On-board Display port.
Try booting .
If you get to the Splash screen, get into the BIOS and change the Graphics Adapter settings. Make the PCIe come first in the order.
Save and Exit.
Connect the Monitor Cable to the GPU cards display port and see if it comes up fine.
And I know that the rigs usually take the GPU plugged into the PCIe slot as primary display adapters but sometime this does not happen.
That is why you need to be sure.


Dec 21, 2011
Well, I had a simular problem, I hookup the ASrock, plug in the I5, hook it all up and start it and all that run are the case and CPU fans. So great, I'm wondering if it's the Mobo so i put the old mobo in and lo and behold the same thing, only fans are running, so now my guess is the PSU, I'll let you know if it's correct.