Question Computer no longer turns on; how do I find the cause?

Anicus

Honorable
Jan 10, 2014
2
0
10,510
0
I built this computer in 2017, and up until very recently, I've had no problems with it. I will leave as detailed a list of the components as i can at the bottom.

I was playing the new call of duty when I saw a flash behind my computer near the wall outlet. Just after this happened, the power went out for a few seconds and then came back on, but my computer would not power on anymore. There was no burnt or fried component smell present. The only indication of power being on when the psu switch is in the on position is the amber light on the ethernet port of the motherboard. It doesn't blink; it just comes on with the psu switch and stays on until the psu is turned off. Additionally my internet/ cable modem's ethernet port( a separate device plugged into the same surge protector) was no longer functional and had to be replaced by my provider's technician. The modem powered on fine and was recieving service from my isp, but the ethernet port no longer sent or received data.

I have taken components out and inspected them, unplugged and reconnected major parts like the gpu, and the computer still does not respond to being powered on. I believe it may be the power supply, but i'll have to wait to purchase a new one. The issue with my modem has me concerned though because whatever happened to it may have also happened to my pc.

My question is: how do i properly troubleshoot the issue? I haven't tested the psu using the paperclip method because i haven't found any clear enough instructions for safely doing so. I'd be willing to give that a go if someone can explain how it's done properly. Also, before my computer died, I'm now realizing that it was giving off a lot of heat... so much so that it was heating the room.

Components of my build are as follows:

Cooler master HAF X full tower case
Intel i7 6700k
Windows 10 64-bit
Z170 mx gaming 5 motherboard
- 850 watt psu 80 plus bronze
M.2 evo 1tb ssd
4x 8gb of ddr4 ram
Aorus 1080 ti gpu
Evo cooler master 212 cpu cooling
1x 3tb mechanical hard drive
2x 1tb mechanical hard drives
And 1x 500gb solid state boot drive for linux

Im not near the system while i write this, so some details like the brand and model of the psu will need to be acquired later. I believe the cpu and gpu were both overclocked, but only slightly and done so using software utilities that came with the hardware like the bios options for my motherboard.

Thank you for taking the time to read all of this.
 
Last edited:

Carl2

Distinguished
Jan 31, 2010
32
1
18,545
0
The power supply paper clip method is rather simple, a YouTube vid explains it well. When using this method you may want to check the output voltages at the same time. I've lost a power supply or two due to dust so now I use filters on all insulations, also had a switch on the computer not working.
I'm working with a Peltier and bought a dedicated Power supply for this, I turn the power supply on and off with a switch, similar to the paper clip method.
 

Anicus

Honorable
Jan 10, 2014
2
0
10,510
0
The power supply paper clip method is rather simple, a YouTube vid explains it well. When using this method you may want to check the output voltages at the same time. I've lost a power supply or two due to dust so now I use filters on all insulations, also had a switch on the computer not working.
I'm working with a Peltier and bought a dedicated Power supply for this, I turn the power supply on and off with a switch, similar to the paper clip method.
Thank you for responding to my post. I am aware of the information regarding the paperclip method that is available on YouTube. Many of the videos that i saw involved people using continuity testing equipment or running the test with the paperclip on a psu with colored wires. My psu is modular and did not come with colored wiring and i don't own or have access to any equipment to test it with. If my power supply is not faulty, i don't want to damage it by incorrectly doing the paperclip test. Ive destroyed electronics in the past by completing a circuit where one never should have been and im afraid of messing this up.

But now that you mention it..Dust might actually be the cause since it's definitely been too long since I've cleaned out my case and blown the dust off the components. For future reference, what kind of filters do you use for your system?
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS