Question Computer not turning on after I tried to install new ram sticks on Asrock H310m-hdv ?

Aug 28, 2021
12
0
10
0
Hi everyone,
I wanted to upgrade my memory ram, and I ordered two new 16gb sticks. I bought from the same frequency of 2666mhz, and supposedly it is compatible.
Some wires were on the way during installation, so I quickly unplugged. Those wires were the wires of the frontal panel on the motherboard.

I didnt think there was an order and quickly installed them back and the computer did not turn back on.

I then looked at the manual of the motherboard and realized there is an order. I looked at the wires and they were labelled power sw, reset sw, hddl + -, and pdl +single and pdl single of -. I tried to install them as it was shown on the manual.

The computer turns on very briefly. The fans spin, the cpu turns on, the gpu turns on. But is very momentarily and it quickly turns back off. And then it tries to power up again on its on and it keeps doing that. At first i thought the new ram sticks were bad, so I put the old ones back. But it still had same issue. I tried to not install the reset switch wire, as thought it was permanently proccing, but didnt work neither. Anyone has an idea what could be possibly going on?

Thank you
 

Ralston18

Titan
Moderator
Update your post to include full system hardware specs and OS information.

Were the new RAM modules a matched pair (kit) for dual channel use?

Double check the motherboard's User Guide/Manual and the applicable User Guide/Manual for the case.

If all connections are correct then it could be that there is a damaged switch, wire, connector, or perhaps a short somewhere.

Use a bright flashlight to carefully inspect everything and pay close attention to the labeling on all pins, plugs, and ports.
 
Aug 28, 2021
12
0
10
0
Yes. The RAM was matched.
It is windows 10. I7-8700 non K. Has one T hdd, one ssd 256, one ssd 1 tera. 2080rtx gpu zoltec. Water cooler.
I used the nanual and matched and still issues
 

ASK THE COMMUNITY

TRENDING THREADS