Computer not working, most likely motherboard problem


Jun 17, 2011
Hi, i recently bought a new barebones package of tigerdirect and a gpu off newegg. Upon assembly of the new computer, everything runs fine and all leds light up, however the monitor does not display anything.

AMD FX-6100 x6 3.3GHz
Sapphire Radeon HD 6850 1gb
Patriot (2x4gb) DDR3 1333MHz Ram
450w PSU
ASUS m5a99x evo motherboard
1TB seagate HDD
mid tower case

At first, i deduced that the problem was the BIOS not working with the newer Bulldozer firmware. So i called ASUS and they said they would send me a new BIOS hardware with software on it. I received the new BIOS on Tuesday, plugged it in, computer runs same as before, and still no image on the monitor.

I've called ASUS numerous times now and done what they said would've fixed it many times, but still not working. The latest i heard was that the RAM isn't supported by the motherboard because it's not listed in the motherboard manual. The last thing i can guess is a problem in the motherboard, but a friend seeing how good the package was, bought the same exact deal except for a different GPU manufacturer. He is experiencing the exact same problem. My last guess is just a fault motherboard, hence the location of the post.

For the past week or so this has caused enough stress for a lifetime. Anyone have a different suggestion? For even my tech savvy friends can't figure this one out.



Jul 1, 2007
I would suggest that what you need to do is to breadboard your mobo or not,, OR,, try to boot from another source, like say, a floppy or a cd/dvd based os, I don't know about the ram situation as I am using Crucial ram that is not "listed" for my Gigabyte mobo, but if possible ,,it would not hurt to try "listed" ram, all things being equal, as it were, do you have another system upon/in which you can test your GPU??...:)