Question Computer Refuses to Sleep When HID-Compliant Device is Connected

Oxiriar Cayton

Prominent
Jan 10, 2020
6
0
510
0
Hello, I've been experiencing this problem for a long time.
I recently have been trying to do some research on it to see if I could finally fix it.
I didn't find many solutions, but the ones I've attempted did nothing, here are the following.
  • Turning off in-game overlay in GeForce Experience
  • Reset/Make custom setting combinations in power management
  • Prevent the device from being able to wake the computer
I had found a page on forums, mentioning it is possible to turn off the devices ability to wake the PC via Command Prompt using the following command.
"powercfg /devicedisablewake "HID-compliant game controller (002)""
However this results in an error saying "You do not have permission to enable or disable device wake"

I'm running on Windows 10 on latest update (2020-11)
and the specific controller I am using is a Hori Battle Pad for the Nintendo Switch.

I appreciate any help I could get
 

ASK THE COMMUNITY