Computer running slow

sheryltoo

Distinguished
Feb 18, 2010
4
0
18,510
I have a Dell Dimension e521 computer that started running really slow awhile ago. I tried restoring the computer back to the factory settings and it didn't help so I ended up bringing it to a repair shop.
After testing everything and manually reinstalling my operating system which is Windows Vista, they decided my hard drive was failing.
I told them not to fix since I figured I could replace the hard drive and when I dug out the discs that came with the computer, I noticed a very important note about being sure you had the updated the drivers for your sata controller.
I didn't have the latest drivers and once I installed them, it seems as if the computer started working much faster, in fact, I don't think it's slow at all.
Could that outdated driver have been my problem all along?

I'm thinking of restoring the computer back to the factory settings since all the extras don't install on a manual install but before I do this and spend a lot more time on it, I want to be sure that that outdated driver could have been my problem.
 

sheryltoo

Distinguished
Feb 18, 2010
4
0
18,510
I'm not so sure any more because it's back to running really slow again.
I did some on line performance test and it says the speed of my c drive is 1mb. I'm not sure what that means but I don't think it's very fast considering I have a 72rpm hard drive.
Maybe my hard drive is failing.
 

sheryltoo

Distinguished
Feb 18, 2010
4
0
18,510
I ran the checkdisk and even though everything came back saying the hard drive was fine, I'm not so sure they were correct because I ended up replacing the hard drive and now the computer is running at a normal speed.
Thanks for the suggestions but it looks like all I needed to do was replace the hard drive.