Question Computer runs, no beeps, but input and output devices don't do anything

Tigerwarrior1

Prominent
Jul 8, 2017
58
0
640
1
Hello, community!

So I've been testing these new stick of rams, and they worked perfectly until I tried overclocking. When I reset the cmos and rebooted, it worked but the ram ran at a slower speed than desired 2666 rating. I tried resetting the cmos again, but this time... everything ran, including the fans, LED's, even my ASTRO mixamp lights turned on, which is normal. But there was no signal on my monitor, and the mouse and rgb keyboard back lighting didn't turn on. I waiting for 5 minutes on a signal, but none. I reset the cmos and switched ram with my old, same thing. Now, I've reset the cmos again, except this time it's just turning everything on and off every 10 secs with no beep. I'm afraid that I screwed up my motherboard or something.

I just really need help.
Thank you for your time!

edit:
Okay so now I've reset the CMOS again, except this time it's not doing the 10 second turn of thing anymore. But still no signal for monitor, LED mouse and keyboard.
Also I've just now noticed that the hard drive LED on my pc case isn't blinking. This could be the problem. One more thing I might suspect, since there's no beeping, it might just be because of my motherboard frying and its completely unresponsive. All of this is boggling with my mind!
 
Last edited:

ASK THE COMMUNITY