Question Computer shuts off while playing certain games

Oct 1, 2019
9
0
10
0
Hi there,

So I recently upgraded my computer from a GTX 960 and i7 3770 16 GB DDR3 RAM to an AMD Ryzen 5 3600, AMD RX 5700, and 16 GB DDR3 RAM with a b450 tomahawk motherboard along with upgrading from Windows 7 to 10. The PSU is an EVGA 500W. Unfortunately when I've been playing some games (such as league of legends and ring of elysium which were both located on my E HDD) it sometimes turns off the monitor abruptly and stops responding (i can stop hearing people on discord/communicating with them), so that I have to long hold the power button and restart my computer. I've ran classic WoW and just done youtube/etc for a few weeks with no instances of this happeng, and I'm not sure if this is just because they're less demanding or because the games that are failing are located on my other drives. I'm currently trying to switch the games to a different drive and see if the problem persists, then that would at least knock out a few suspicions.

I'm not sure if this is connected but my computer will not awake up from a sleep, rather it just lights up my keyboard and mouse for a few seconds then they go dark again and I have to long hold the power button. I've tried going into the BIOS and changing waking the sleep to OS, changed it so that USB can wake my monitor, and turned off hibernate.

Some things about what I find may be the issue:
• Failing PSU (although it ran completely fine on my other computer 2 weeks ago, could need one to draw more power for new components?)
• Both games are located on the same drive.
• Whenever I installed my GPU it never got the clicking sound that you usually get when you install RAM/GPU etc, although I applied quite some force and it seems pretty steady in the PCI-e slot and screwed in
Possibly it's overheating and slipping the GPU connection from the PCI-E slot? (although it rarely ever goes above 75 C)

EDIT: Also I'm not sure if it matters, but I'm running 1x DP 1920x1080 144hz monitor, 1x DP to DVI adapter 1920x1080 60hz monitor, and 1x DP to DVI 1600x900 60hz monitor and sometimes when I turn on the monitors or start my computer the 1x DP to DVI adapter 1920x1080 60hz monitor comes on with grey static and I have to turn it off/on until the display is working correctly
 
Oct 1, 2019
9
0
10
0
model of this EVGA psu?
RX 5700 recommend 600W psu
It's an EVGA 500W product # 100-W1-0500-KR, I just see now that it's minimum 600W, recommended 700W PSU for the rx 5700 on the amd pdf, I'll try upgrading this and see if it makes a difference, thanks!
 
Oct 1, 2019
9
0
10
0
It's an EVGA 500W product # 100-W1-0500-KR, I just see now that it's minimum 600W, recommended 700W PSU for the rx 5700 on the amd pdf, I'll try upgrading this and see if it makes a difference, thanks!
Unfortunately it's going to be a while since I got sent a PSU that was DOA, go figure 😒
 

ASK THE COMMUNITY

TRENDING THREADS