• Find an incredible deal for Black Friday or Cyber Monday? Share those epic bargains with the community by posting them in this forum thread!

Question Computer shutting down and no signal status

Nov 8, 2019
2
0
10
0
Hi everyone...I really need your help!
Here is the problem:
While I was surfing on the internet my computer crashed and restarted itself with a No Signal message on the screen. I tried restarting it a few times but didn’t work.
So I decided to open it, remove my VGA (GTX 1070) and connect a DVI cable to the integrated graphic card...computer turned on but “No Signal”.
Checked all the RAMs by removing them one by one. One RAM didn’t work so I tested the computer with the other two. It worked perfectly. So I reinstalled the VGA and tested again...it worked. I tried to install the “defective” RAM in another slot and guess what...it worked.
After like 30 minutes computer crashed again with a no signal status on the screen. Removed the “defective” RAM but still no signal status.
I have no idea what’s going on with it.
P.S.:sorry for my English but it’s not my native language.

I don’t know if this can help but keyboard doesn’t work while mouse does (tried connecting them in the same USB port). This is so strange...
 
Last edited:
Nov 8, 2019
2
0
10
0
full system spec? include make and model of the psu
CPU: Intel Core i5 7500
HS: Cooler Master Seidon 120M
MB: AsRock H270 Pro4
RAM: Corsair Vengeance LPX 2400Mhz 4x4Gb
VGA: Asus GTX 1070 Strix
PSU: Thermaltake TR2 S 600watts
SSD: WD Black M2 2280
HDD: Western Digital Caviar Black
 

ASK THE COMMUNITY

TRENDING THREADS