Question Computer stopped booting, motherboard decorative LEDs light up when plugged in, but doesn't boot/post

Dec 22, 2020
2
0
10
0
Hello. One of my computers has decided to stop booting. It was assembled July last year and has worked fine since. When switched on at the wall the decorative LEDs on the motherboard light up, but when you press the power button (or short the pins directly on the board) NOTHING happens. No sounds/beeps, the fans don't spin, just nothing.

It was working perfectly fine the other day. Just before it died it was having trouble remembering the time, the CR2032 battery still had just over 3 volts, and I swapped it as part of diagnosing it, to no avail.

Parts list:
  • Asus Prime A320M-K
  • Ryzen 3 2200G (APU)
  • G.Skill 8GB DDR4 2400MHz (single stick)
  • Corsair CX600M PSU
  • no graphics card
Things I've tried
  • re-seating the CPU
  • re-seating the RAM
  • cleared the CMOS
  • changed the CR2032 battery
  • removed all cables from mobo, SATA, f-panel pins, etc
  • paper clip test on the PSU, fan spins
  • sprayed the motherboard with compressed air to clean it
After all that still nothing. So basically, as best I can tell, it's either the motherboard or the CPU. I have no other CPUs I can test with. Any thoughts on how I can figure out which is the culprit?
 
Last edited:

ASK THE COMMUNITY