Question Computer turns on and off repeatedly after trying dual channel ram

Teeler

Commendable
Jan 31, 2017
26
0
1,530
0
I have 2 8gb EVGA DDR4 3000 ram sticks or whatever they are called and I tried to put it into the slots of my Z270x-Gaming 7 Motherboard by aorus for dual channel ram but when i try the first and third slot it doesnt work, and when i put it in the second and fourth slot it doesnt work. The computer just turns on, I can hear the fans rev up and down, and there are two little red dots on the part of the mother board that gives errors and they just flash back and forth. Eventaully after a few seconds of this the computer turns off everything goes dark and it repeats the cycle over and over again. When I run my computer with the ram in the second and third slot it works but when i open cpu-z it just says i have "Channel # single" and it also says Size "16 GBytes" My computer also runs when the ram is in the third and forth slot, I have not tried it on the first and second. But it just gives the same results in CPU-z I dont know why this isnt working and I would appreciate some assistance.

I also am experiencing low frames in video games and my CPU is almost always 100% for Rainbow Six Siege. I dont know if this is related or not but I thought it was worth mentioning.
 

ASK THE COMMUNITY

TRENDING THREADS