Question Computer turns on but displays nothing after using sleep mode, help!

Nov 21, 2020
1
0
10
0
Hello! I'm sorry if I leave any information out or I miss important steps, I'm not too experienced with computer issues like this so I've done all I can think of (and this is my first time posting here).

About two weeks ago, I was using my computer normally when I accidentally pressed the "Sleep" button on my keyboard, which puts the computer in sleep mode. For some reason (I'll have to fix this after I finish the major issue), sleep mode on my PC is very strange, and it completely shuts down my computer when it's used. When I clicked the multimedia sleep key on accident, I tried to stop the computer from going into sleep mode by hitting random buttons on the keyboard, but it didn't work and the computer turned off (not fully, the power button light was blinking on and off but I have to turn it off to stop that). When I hard-restarted the computer by holding down the power button, and turned the computer back on, nothing displayed on either of my monitors. Ever since then, the display on my computer has not worked at all. The strangest part is that literally everything else on my computer has worked. I have been able to successfully turn on the computer multiple times, and even was able to boot into Windows, sign in with muscle memory on the keyboard, and hear Windows notification sounds through my Bluetooth headphones, but the display doesn't work. I have tried:
  • Turning the computer on and off multiple times
  • Unplugging everything from the computer except the monitor(s) and power cord
  • Using the monitors on a different computer (they work on other computers)
  • Plugging in only one of the monitors
  • Taking out the GPU and plugging monitors into motherboard
  • Swapping the input and output of the HDMI cable
  • Leaving my computer off for days before coming back to it
I can't think of much else to do. I think it's most likely a software or motherboard issue, where somehow my computer still thinks it's in sleep mode and keeps the displays off to preserve power. Any help would be greatly appreciated, as I've tried everything that I can think of doing. I'm not very experienced with advanced computer troubleshooting. Here's my list of specs, and if you need any more information I'll try to get it (just keep in mind that I can't use my display to find the specs).

CPU: AMD Ryzen 5 1400 3.2 GHz (3.4 GHz Turbo) 4-Core Socket AM4 8MB Cache Desktop Pro
Graphics Card: XFX - AMD Radeon RX 580 GTS Black Edition 8GB GDDR5 PCI Express 3.0
Motherboard: ASRock A320M-HDV R4.0
Power Supply: Viotek 600W 20/24 Pin Power Supply with PCI Express & SATA
RAM: Corsair Vengeance LPX 8GB (1 x 8GB) DDR4 DRAM 2400MHz C16
Hard Drive: SAMSUNG 850 EVO Series 250GB Solid State Hard Drive
Case: Rosewill FBM-01
Keyboard: Redragon S101-1 (only the keyboard)

Thank you!
 
Last edited:

ASK THE COMMUNITY