• Our team is working to address issues posting quotes or media to the forums. Please bear with us as we get this sorted out.

[SOLVED] Computer turns on but no display , cannot turn off power unless i use the power supply switch.

Aug 14, 2020
5
0
10
0
Hello,
Recently my computer randomly stopped displaying after i came back from vacation. All my fans and LED lights turn on, and i hear a short beep when i power it on, but in order to turn it off i have to flip the power supply switch because the power button has stopped working. My USB ports are not working either.
Here are the things I have tried that have not worked:
• Replacing my power supply
• Taking out my CMOS battery and putting it back in
• Trying both of my ram sticks individually in seperate boots
• replugging the sata cable
• replugging all the power supply cables
• Trying my intergrated graphics rather than my GPU
• Taking GPU out and then taking cmos battery out
• Using a VGA cable rather than hdmi
• Using a different monitor

These are my computer specs

• AMD ryzen 5 2600x
•ThermalTake Smart 700W
•Ripjaws G.skill v series 2x8gb ram (DDR4)
•MSI B350M motherboard
•Apevia Aura Pink Case
•2TB Seagate Internal Hard drive
• XFX Radeon RX 570 RS XXX Edition

Side note: my Bios is updated

Thanks!
 

simonyeeklang

Distinguished
BANNED
Aug 22, 2011
170
16
18,615
38
10A is 10 amps.
IS-14 maybe standard apply to the cable.

You might have left the pc plugged in and then a lightning strike
but let's try this way remove all the component out from the case look at everything with a magnifying glass
check for the burning smell.
And then try to assemble everything out of the box (no casing)
And turn on see if that works.
 

simonyeeklang

Distinguished
BANNED
Aug 22, 2011
170
16
18,615
38
10A is 10 amps.
IS-14 maybe standard apply to the cable.

You might have left the pc plugged in and then a lightning strike
but let's try this way remove all the component out from the case look at everything with a magnifying glass
check for the burning smell.
And then try to assemble everything out of the box (no casing)
And turn on see if that works.
 

ASK THE COMMUNITY