Question Computer turns on but no signal PLEASE HELP

Apr 3, 2021
3
0
10
0
Hey, I just finished building my PC and it boots the led‘s and fans turn on but I get no signal and my keyboard and mouse dont get power and in the beginning my graphics cards fans start to spin then they stop also idk if thats the case but the leds on my graphics card dont turn on but idk since its the first boot it doesnt beep either after turning it on, ill give you my basic specs first. Rtx 2060, asrock z270 pro4, I7-7700, 16GB Ram(2x8), 500GB SSD, 2TB HDD, 650W Corsair PSU, the only parts I bought used is my case and the motherboard, after trying it the first time I realized that the motherboard might be dead so I bought a new one that was actually new, I tried a different CPU, ram, I checked all of my cable connections which since its my first time actually building one im not so sure I tried resetting cmos. Basically to keep it short i tried everything I could find on the internet and idk it could be im really helpless and im loosing motivation I hope somebody can help me. I took some pics but I have no idea how to post them
 
Last edited:

Lutfij

Titan
Moderator
Welcome to the forums, newcomer!

Corsair is the brand of the PSU while 650W is the wattage. We will need to know the model of the PSU. How old is the unit in the build? You will need to check and see if the CPU socket has any bent or broken pins.

Also given how you have an i7, you should be able to get display out of the board's display output ports. breadboard the system with only the bare minimum. What slots are the sticks of ram populating?

Might want to list your specs with more detail such as the make and models of the ram, the SSD and the HDD.
 
Apr 3, 2021
3
0
10
0
Welcome to the forums, newcomer!

Corsair is the brand of the PSU while 650W is the wattage. We will need to know the model of the PSU. How old is the unit in the build? You will need to check and see if the CPU socket has any bent or broken pins.

Also given how you have an i7, you should be able to get display out of the board's display output ports. breadboard the system with only the bare minimum. What slots are the sticks of ram populating?

Might want to list your specs with more detail such as the make and models of the ram, the SSD and the HDD.
the PSU is brand new its a VS650 my ram is the corsair vengeance rgb pro, on the old board there were 2 bent pins on the new one none and it still doesn’t work, idk what u exactly mean with the processor part but my ssd is from wd blue and the hdd is from seagate
 
Apr 3, 2021
3
0
10
0
Welcome to the forums, newcomer!

Corsair is the brand of the PSU while 650W is the wattage. We will need to know the model of the PSU. How old is the unit in the build? You will need to check and see if the CPU socket has any bent or broken pins.

Also given how you have an i7, you should be able to get display out of the board's display output ports. breadboard the system with only the bare minimum. What slots are the sticks of ram populating?

Might want to list your specs with more detail such as the make and models of the ram, the SSD and the HDD.
the ram is seated in slot a2 and b2
 

ASK THE COMMUNITY