Computer turns on & off as soon I press the power button.

Zeus91

Prominent
Jul 4, 2017
30
0
530
0
Hey guys I need help. For some reason whenever I press the power button on now, my CPU fan, gpu & everything else turns on for a brief second but then it turns off & it repeats over & over again. My computer was working just fine earlier today when I was playing. I remember I switch the button off for the power supply from the back but when I switched it back up that's when I started having this issue. Any help or advice would be nice.
 
The power switch is connected straight to the mainboard, which actually turns on the PSU. A stuck switch could wreak havoc, but, you could temporarily reconnect your reset switch set of wires to function as a PWR SW to rule this out.

PSU itself might have gone out, and, it would be a candidate for any set of symptoms with a PC now not fully powering on. Borrow/temporarily insert a good PSU of sufficient wattage to effectively assist in ruling out the other PSU.

Once ruling out switch wires, PSU, you are left with mainboard, and, lastly CPU.

(You can try disconnecting power to all nonessential devices required for power up/POST, such as power connection to all SATA devices, etc...; if your CPU and MB support inegrated graphics, you can remove whatever GPU you are using, essentially attempting to see if perhaps your GPU is/was loading down your system.
 

Zeus91

Prominent
Jul 4, 2017
30
0
530
0
My CPU doesn't have IGPU as I'm using a Xeon 1231 v3. I didn't have issue at all as I just recently bought my Xeon last December & my gtx 1060 on May. As far as my psu I recently bought that as well just last year. It's a Seasonic Mii12 Evo 520.
 

Zeus91

Prominent
Jul 4, 2017
30
0
530
0
So after swapping out my PSU for my old one, it still kept giving me issues. So what I've decided to do next was to to swap out my current CPU for my old Pentium. It turns out that my Pentium turned on without a issue thus indicating that it was indeed my Xeon CPU ;( which sucks cause like I said, I just got this CPU.
 

ASK THE COMMUNITY