[SOLVED] Computer wake up immediately after going in sleep mode

Oct 16, 2021
10
0
10
0
Hi,
My computer wake up immediately after going in sleep mode and the fans spins really fast for about 20 seconds.
I found this in the event viewer right after the computer wakes up.
Wake Source: Device -PCI Express Root Port

Here are my specs.
Windows 10
ryzen 2700
32gb corsair vengeance 3600mhz
gigabyte b450 aorus elite v2
rx 480
Corsair hx 850.
 
isn't the same as in the event viewer?
it should be same as in event viewer..now i noticed you already posted your wake device (pcie express hub)

powercfg -devicequery wake_armed

this one will show you all devices which can wakup your PC from sleep state
see the list if you see any device you dont want for pc wake up, then go to device manager to find that device and under properties -> power management, dont allow to wake up pc (uncheck mark it)
 
Reactions: EpselonZero
usually this is caused by an external device trying to communicate with the system while it is asleep, hibernating, etc.
but it can also be caused by a corrupt OS.

you can try disconnecting all USB & HDMI devices and see if it still occurs.

fans spinning up upon awakening isn't usually a cause for concern.
usually it happens before any set fan profile has initiated.
does the same thing not happen when you normally awaken the system or start it up from a fresh boot?
 
Oct 16, 2021
10
0
10
0
I had to disable wake on lan in the bios. If I let wake on lan enabled I can't shut down my pc. it restarts when I try to shut it down. I don't know if this is related.
I tried without any usb devices even without ethernet cable, only my monitor connected and I had the same issue.
 
isn't the same as in the event viewer?
it should be same as in event viewer..now i noticed you already posted your wake device (pcie express hub)

powercfg -devicequery wake_armed

this one will show you all devices which can wakup your PC from sleep state
see the list if you see any device you dont want for pc wake up, then go to device manager to find that device and under properties -> power management, dont allow to wake up pc (uncheck mark it)
 
Reactions: EpselonZero
Oct 16, 2021
10
0
10
0
It was the keyboard. I had 2 hid keyboard device and one of them was causing the issue.
Thanks guys!
Do you guys know why If I enable wake on lan in the bios I can't shut down the pc. When I try to shut down my computer it just reboot.
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS