Question Computer won't boot after power loss until BIOS Reset ?


Jun 18, 2012
First thing's first, I have already replaced the CMOS battery!

The Build:
CPU: Intel 12900k
Motherboard: ASUS ROG STRIX Z690E
Memory: G.Skill DDR5 32gb
Storage: 2TB 980 PRO
GPU: RTX 3080ti
PSU: Seasonic Prime TX-1000W
Chassis: Fractal Torrent

Okay so my computer suffers from a few different issues that I think may be connected by a root issue. The biggest problems are with the motherboard.
  • If the computer loses power (unplugged from wall, etc.), it will not boot until I reset the BIOS. It will be an infinite load (it's been a while since I've had to unplug it). Have to hold the BIOS reset on back of mobo, then f1 to get into bios. Very annoying and moving my pc means losing all my settings.
  • Computer will randomly blue screen, address/highlighted file in BlueScreenView is ntoskrnl.exe. It will also bluescreen when I leave my computer locked instead of powered off. I notice the most common way to get a BSOD is by locking my pc. It's not every time, but it feels around 15-20% of the time a lock means BSOD. Usually I only notice it occurred by how everything suddenly starts loading when I login as if it was first boot up (compared to when I actually lock and sign back in).
  • Any attempt of OC memory to get the advertised 6000 MHz leads to constant bluescreens/failure to boot.
  • Every now and then, red blinking red lights will trigger on my GPU, which I believe means there's not enough power to the GPU. However I believe this is triggered sometimes when I'm powering down. I had a previous 3080ti that randomly died a little while back, got it RMA'd and the new one has this issue quite a bit. I don't remember at this point if my old one had this issue as it died pretty early.
  • If I plug my DAC/AMP for my headphones into my motherboard using S/PDIF, the audio will cut every 5 seconds. Tbh I'm not sure if this one is related but it's quite annoying, and any fix for this is hugely appreciated. I use a FIIO K5 PRO.
Anyone have idea on what the real culprit is here. I have gone from thinking its a memory issue until I ran memtest86 and had flawless results, then I thought it was a power issue, which isn't off the table, but doesn't necessarily coincide with all issues, which leads me to believe it is motherboard based?


Jun 18, 2012
Is your motherboard updated to the latest audio drivers, chipset drivers and BIOS?
I have gone through that process and updated. It was weird for the ME update, as there were two different downloads. Downloaded BIOS to update that and ran the tool I believe. Otherwise I used Armoury Crate for most of those.


Jun 12, 2023
OP, running memtest86 & passing all the tests does not necessarily guarantee stability under load in windows. You should also run the built in windows memory diagnostic utility & check the results when it reboots again.

But also, even after running the built in windows memory diagnostic utility, its still not guaranteed the system RAM is stable when under loads like benching, gaming, etc.. I've seen this on AM5 platforms until I successfully run a 3rd party tool to stress system RAM even more like memtestpro or prime 95 large ffts. Either of those should be run for a few hrs at least win no errors reported of course, for 32GB capacity.

Another thing too, is your RAM listed on the support list for your motherboard? It's not clear what specific set of RAM your G.Skill is.