Computer wont boot but everything seems fine

Oct 25, 2018
4
0
10
0
Hi ! I built a Gaming PC a year ago and I made it cheap, but it turned out great as I was able to play recent games with great graphics !

Set up: HDD-Seagate Barracuda 1tb PSU-coolmax of 500w (really cheap) CPU- i5-7400 3ghz GPU-GTX 1050-ti Optical Drive MOBO-MSI B250M Gaming Pro mATX LGA1151 ddr4 RAM-Patriot 8gb ddr4

So... I did this on pcpartpicker and everything is compatible and worked fine for a year.

I dont overload my computer as I only have 300gb used on 1tb and I analyse my computer monthly for viruses

But now, it freezes randomly, even though I tested CPU temp and % utilization. My HDD sometimes goes up to 100 but I'm not sure it is the problem, but I'm no pro either.

Moreover, last time it froze, I tried to reboot it and it just powered on, then off 2 seconds later reapetedly, as if it was lacking juice. One time nothing appeared on my monitor and mouse and keyboard seemed unplugged, even though the 3 of them were plugged, I managed to make them work by unplugging, and rebooting. But tonight, I made a final test running a full pc analyse for viruses and found nothing. After I tried playing a game and it froze again. I had to reboot it and it would not even get to homepage of windows 10. It would froze on the screen where you can press "del" or "f11" for BIOS or boot menu, or something like that...

What piece do I need to change? Whats the problem?

Thanks !
 
Oct 25, 2018
4
0
10
0
Hey ! I'm updating, ad i'm frustrated. So I tried booting the computer with the HDD unplugged and it did the exact same thing : inifinite restarts after a boot of 3sec. So I decided to change the PSU for a great one with good reviews and the damn thing is having the SAME DAMN ISSUE... I dont know what to do nor what to think...
 

ASK THE COMMUNITY