Question Computer Won't Boot, MOBO Only Has Flashing PWR LED

Mar 11, 2019
1
0
10
0
Hello everyone. About a week ago I was using my PC watching Netflix when it suddenly shut off after about 20 minutes of use. Confused, I tried powering it back on, but got no response. I try the normal things like powering off the main switch in the back, letting it sit for a bit, trying to power it on and nothing. I tried using a different surge protector, plugged directly into the wall, moved it to a different outlet that I know is on a different circuit and still no luck.

Opened my case up to see if I could diagnose it. Right away I see that the PWR LED is briefly flashing orange once every 3-4 seconds while it is plugged in and the main switch in the back is turned on. No response at all from the system (no fans, no lights) when I attempted to hit the power button in the front of the case. I checked all the wires to make sure they were plugged in properly. Everything seemed fine. Tried unplugging everything one at a time, testing the power each time. Still just a flashing PWR LED light. Took the opportunity to inspect the pins before plugging stuff back in and they all seemed to be fine.

I then tried breadboarding my PC, getting it as far down as to just the MOBO, CPU, PSU and one stick of ram (I have 2 and tried each one at a time). Still got the flashing PWR LED, so I feel its safe to say that it isn't any faulty wires in the case or any unintentional grounding.

I have also now tried 3 separate PSUs (one spare that's the exact same as in my build and one from an old PC). 3 separate sets of cables as well. No change between any of them. Tested PSU with my old PC and they all powered it fine.

I have also attempted to reset the CMOS battery.

I've had no luck looking up this issue. The Asus MOBO manual does not provide any explanation for what the behaviors of the LED lights are other than identifying them, the same as they are labeled on the MOBO itself. I've similarly had little luck online. As far as I am aware, my computer case does not have any built in speakers, so I have not be able to listen for a beep code.

At this point, I believe the issue to either be the MOBO or the CPU, but I would like to be certain before moving forward. Both would be somewhat expensive to replace and I see little other than horror stories about the RMA process regarding time to completion. I plan to stop at an electronics store and pick up new thermal paste and clean and reseat the CPU when I get home from work to see if that was the issue, but in the meantime was looking to see if anyone here had any input on what the potential issue could be and maybe suggest if I had overlooked anything.

Thank you in advance.

PC Specs are as follows:
Asus z270e MOBO
Intel Core i7-7700 CPU
DDR-4 RAM 32-GB (2x16)
GTX 1080
EVGA 650 GQ, 80+ Gold 650W PSU
Windows 10 64-bit

Please excuse me if I'm missing any relevant specs. Posted from memory. Case make and model is currently escaping me. Will update once I am home.
 

ASK THE COMMUNITY