Question computer won't start with LED ON

Oct 22, 2019
1
0
10
0
computer suddenly became unable to be turned on... (not passing POST)... after a hard shutdown, it could boot up into windows but after a couple minutes mouse, keyboard, and other devices didn't work (off) and then the screen went black (monitor didn't get signal) but the power button led stayed on. after that, the pc sometimes able to boot only for a couple minutes and the black screen happened again.

I tried to reseat the processor, graphics card, and the ram then clean the pc from dust. but now it won't boot at all. if i push power button, the led turns on but no sign that the computer (even psu's fan) start to work. i tried a to check the component the psu is working, processor and ram is working and gpu card is working as well.

I only find that if my motherboard's 4pin connector (cpu) is connected, even the psu won't start. does that mean my motherboard is toasted? if so, can anyone tell me why? because yesterday it works flawlessly and no update or anything else. Just normal daily use of photoshop and illustrator.

My pc was:
CPU: Athlon X4 880K
Motherboard: asrock fm2a68m-dg3+
RAM : 12GB ddr3 (1x4 & 1x8) @1600Mhz
PSU : Seasonic S12ii 520W 80+ Bronze
 

R_1

Judicious
Herald
step 17 what is your speaker saying?

canned diagnostic speaker rant: speaker making 101
The diagnostic speaker is the motherboards main diagnostic feedback device.
the motherboard may be telling you where the problem is.
my speakers have this plug
http://images.crutchfieldonline.com/graphics/infolib/homelib/hSpeakerSpringClip.jpg
I use lamp wire but any stranded wire will do. literally any stranded wires. strip one end like so
http://www.antiquelampco.com/Shades/CordColors.jpg
attach the stripped end into the speaker spring clips on the speaker.
the other end of the wire should be trimmed like so the semi strip
https://wesbellwireandcable.com/images/cutwire.png
by doing a semi strip the wire case is now the socket.
plug one wire to the first pin, and the second onto the fourth pin.
power on the system and listen for beeps
end canned rant

to test the motherboard remove the RAM and try to boot with the speaker connected, this should universally trigger the no RAM boot code. if you cannot force a beep code in this way in my experience the motherboard is dead.

as to why it happened, IDK. everything works till it doesn't.
 

ASK THE COMMUNITY

TRENDING THREADS