Computer won't start with more than one DIMM connected



I should probably explain my issue with more details:

I have the following configuration:

-Motherboard: MSI P35 NEO2-FR
-RAM: Corsair 2 GB DDR2 11066 MHz CL5 Dual Channel
-Video Card: Gainward Bliss 8800GT
-PSU: Thermaltake W0089RE TR2 470 W

I bought it in 2008. Everything worked perfectly until a few weeks ago when out of the blue the computer stopped. I tried to restart it, it never loaded BIOS or anything else, it simply started and stopped after a few seconds (sometimes not stopping at all, it kept on working but without displaying anything on the monitor and with the indicator LEDs going beserk). Anyway I managed to fix that, BIOS update did the trick. One week ago it did it again. I was not home so my mother used it, it simply stopped and refused to start again. When I returned home I was prepared to re-update the BIOS but I did not have to because the computer simply decided to work, until today. However today it did something different. BSOD for a second (I couldn't get any info out of there), it rebooted, then worked for another couple of hours and then started dumping memory (or that's how the ubuntu crash screen describet it) then stopped. I cleared the CMOS, which did the trick in the past but nothing happened. After that I read the motherboard manual to make some sense out of the LED indicators. The sequence was Red Red Green Red. The manual section for that code says:

"Memory Detection Set
Testing onboard memory size. The D led will hang if the memory module is damaged or not installed properly"

After reading that I removed the DIMM_B1 module (I was using the DIMM_A1, DIMM_B1 combo so that my modules worked in dual channel). Now with only the DIMM_A1 module installed the computer works like a charm, no errors, no BSOD, no power failure, nothing.

My question is: what should I do in this situation? because I cannot seem to figure out what is broked (the module or the DIMM_B memory channel). I tried to use the modules in single channel (connected the second module to DIMM_A2) and the computer failed to start again! Could it be the motherboard's fault or I simply have to replace the memory module and it will work.

I sincerely appopogise for the long post and for the grammar mistakes (if any). I would really appreciate an answer to my question.

I thank you in advance!


Firstly, thanks for the answer.
Secondly I have a few follow-up questions:
1. How can the bad memory create something that looked like a power failure, I mean until today there was no BSOD no nothig, it simply stopped working.
2. If I decide to completely replace the memory kit, would a DDR3 one work with my configuration?

Also I would like to ask if my problem could have something to do with the age of my motherboard. I mean I know that after a certain time of usage capacitors become faulty, swell, and work at different parameters that normal. What I do not know is the actual effect that has on the functionality of the computer and the amount of time necessary for a capacitor to become faulty.