Computer won't turn on after installing new cpu cooler

Sam_ramos_02

Prominent
Aug 15, 2017
25
0
530
0
Hi guys, I would really appreciate any kind of help. sorry if it feels really long and boring :/

Today, I bought my new CPU cooler; Cooler master T2 upgrade from a stock cooler. after installing it, i started up my PC all excited ready to test the new cooler soon to find out that whenever i reach the login screen my computer would freeze and my display would go on and off. also when i was typing the password £/ would type 3-4 letter when i press 1 key.

After trying to replace, rotate trying to fix the problem, looking up online for advice (tom's hardware) I was unfortunately out of luck. I spilled a tiny bit of some thermal paste on my motherboard i don't know if that caused the issue.

Finally, i removed the cooler itself and looked at the cpu to see if there was any thermal paste on the sides. Then i see 1-2 pins bent from my cpu. I really don't know what caused this because i never even touched the back pins which i know are very important.

I put everything back in place and started up my computer but now IT WON'T EVEN TURN ON. my CPU fan is spinning the GPU too but there is only one fan on the back that is connected to the motherboard that won't spin.

Currently I'm thinking i must of messed up something which completely destroyed my PC. I'm so <<Inappropriate content removed by moderator.>> sad/frustrated.
 

Sam_ramos_02

Prominent
Aug 15, 2017
25
0
530
0
I did bend the cpu pins back because there was only 1-2 pins that were slightly bended...but still no post. heatsink fan spin but not the case fan 92mm.
 

Od1n

Honorable
Jan 9, 2014
45
0
10,540
2
When I had AMD CPU I managed to bend a couple of pins too. But I remember taking a neddle or smth to bend them up right. Once that was done I took my Credit card (some can fit perfectly) and simply let it slid through in all dierections like this #, many times. It worked out for me. I found a nice "guide" about this somewhere.

I went from half or pitch black screen to fully operational CPU. Try doing the same.
Good luck
 

Sam_ramos_02

Prominent
Aug 15, 2017
25
0
530
0
Hey that actually worked (only a small bit)
i managed to bend the pins a bit more straight with a credit card and tweezers which solved the fan that wasn't spining from my pc.
i'm still getting no post though. thanks for the help :)
 

Sam_ramos_02

Prominent
Aug 15, 2017
25
0
530
0
no they're as sraight as they can be. i'll send them for diagnostic service cause I'm thinking it might be a bad motherboard, cpu or maybe psu...
 

Similar threads


ASK THE COMMUNITY