Question Computer won't write to USB flash drive but other household computers can ?


Sep 3, 2009

For some reason my Windows 11 PC won't write to a usb flash drive. I've tried all the internet solutions and to no avail. It just keeps saying the drive is write protected. I've used new drives, old drives, formatted them everything.
If I try them on another PC there is no issue so it must be this PC.

What could be the problem?


Make and model usb flash drive?

What specific internet solutions have been tried?

= = = =

As I understand your post it is very likely that your user account on that Windows 11 PC does not have the necessary rights/permissions to read and/or write to a USB flash drive. Especially if the flash drive can be written on via other household computers.

Do two things:

1) With the usb flash drive plugged in, open Disk Management, expand so all can be seen, and take a screenshot.

Post the screenshot here via imgur (

2) Attempt to write to the USB. When the "write-protected" message appears likewise take a screen shot and post that image as well.