Question Confused over USB 3.0 port for external drive ?

Salamat1

Commendable
Dec 2, 2019
6
1
1,515
0
I have an NVMe drive (WD SN750 500GB) in a caddy, which can use either USB type A or type B. My mini pc only has ports described as USB2 and USB3. However, when I run CrystalDiskMark I get the following speeds:



So, my confusion is, the port on my mini pc surely has to be faster than 3.0? Am I right, if so, what will it be?

Thanks
 

Salamat1

Commendable
Dec 2, 2019
6
1
1,515
0
must be 3.1 gen 2
Thanks for replying. So, going by this Kingston site, 3.1 Gen 2 is also known as 3.2 Gen 2x1 ???
Confusing, or what! Why on earth didn't they use different colour inserts in all the sockets and cables, so you can tell the difference!

 
Here's a 4GB test

Just needed confirmation because I've seen behavior in some USB drives where it appears to be faster than it really is because of write caching. Testing with a sufficiently large size ensures you're not hitting that.

Thanks for replying. So, going by this Kingston site, 3.1 Gen 2 is also known as 3.2 Gen 2x1 ???
Confusing, or what! Why on earth didn't they use different colour inserts in all the sockets and cables, so you can tell the difference!

The host USB port (the thing you plug the device into) is supposed to use different colored ports to differentiate which one it's supposed to be:


(Note that SuperSpeed is 5Gbps and SuperSpeed+ is 10Gbps)

The port on the device end is a different story, given how small they are.

Coloring the cable itself doesn't matter, because as long as it has enough pins and the cable was built well enough, it can support anything. A cable released during the SuperSpeed days can work with a SuperSpeed+ port. It's similar with HDMI. You don't need to buy an HDMI 2.1 cable, you may already have a cable that does the job.
 
Reactions: Salamat1

Salamat1

Commendable
Dec 2, 2019
6
1
1,515
0
But, shouldn't the cable have 'SS' on it, to be sure it's capable of all Superspeeds?

As an aside, it seems strange for a PC vendor to describe an item as having 3.0 ports, when in fact they're 3.1 or better!
 

ASK THE COMMUNITY