Question Confused what is wrong here :(

hashim1991

Distinguished
Nov 23, 2013
88
2
18,635
0
My motherboard creating a beep on VGA slot and there is no display as-well. I started using this graphics card after a week ( It was working fine on different machine). What could be wrong here ? Perhaps the fault could be on my motherboard or something else ?. I never experienced such thing before, Whenever my card got faulty either it gives no display or don't run the system at all but this beep thing is new to me.
 

RealBeast

Titan
Moderator
My motherboard creating a beep on VGA slot and there is no display as-well. I started using this graphics card after a week ( It was working fine on different machine). What could be wrong here ? Perhaps the fault could be on my motherboard or something else ?. I never experienced such thing before, Whenever my card got faulty either it gives no display or don't run the system at all but this beep thing is new to me.
Some part model numbers for the motherboard, GPU, and PSU would help, but since the GPU works on another machine I expect that it is okay.
Did you remove all old drivers from the new machine if it had any? DDU works well.
Are the correct additional power connectors (if any) firmly attached?
Is the GPU well seated (sometimes the backplate keeps them from fully engaging and needs to be loosened to change the angle slightly)?
Did another GPU work on that motherboard? Is there a second GPU slot to try?
 

hashim1991

Distinguished
Nov 23, 2013
88
2
18,635
0
GTX 950 2 GB graphics card. I just want to know if bad graphics card can cause such beeps or it's motherboard issue ? Yes graphics card was working on other system few days ago but sadly i don't have other system to check it right now.
 

ASK THE COMMUNITY

TRENDING THREADS