Question Connecting to external computer with Remote Desktop.

iJosh

Prominent
Jul 20, 2019
26
1
535
0
Currently trying to set up remote desktop connection so that I can access my home pc while at work. Using my phone on data I can access my home pc via the Public IP. However, when I try to connect on the work laptops with the exact same settings, it just refuses to connect, and I have no idea why.

Modem model is Arris DG3270, this is my port forwarding setup:


EDIT: Updated description of problem, was using my device's IP as gateway when I didn't need to. Also Updated from just TCP to Both UDP and TCP in port forwarding, still doesn't let me connect through the laptop at work.
 
Last edited:
Sep 12, 2020
142
30
140
15
In your screenshot, to the left of RD_Gateway, there's a white box. It must be there for a reason so is it a check box for enabling/disabling the port forward? Click on it and see what happens.
 
When connecting from an external connection, I use the Public IP as the RD Gateway and the Local IP as the computer name. Am I doing something wrong?
Yes, wrong.
RD gateway is a completely different thing. That is feature of Windows Server OS. It allows to connect to Remote Desktop via HTTPS protocol.
You most certainly don't have it.

From external location you have to connect to public IP of your router. Do not use RD Gateway Server option.

Edit: Change description of port forward rule to something else. It is not RD_Gateway. Just causes confusion.
 

iJosh

Prominent
Jul 20, 2019
26
1
535
0
In your screenshot, to the left of RD_Gateway, there's a white box. It must be there for a reason so is it a check box for enabling/disabling the port forward? Click on it and see what happens.
That's the check box for deleting fields. Will admit their UI is a little confusing.
Yes, wrong.
RD gateway is a completely different thing. That is feature of Windows Server OS. It allows to connect to Remote Desktop via HTTPS protocol.
You most certainly don't have it.

From external location you have to connect to public IP of your router. Do not use RD Gateway Server option.

Edit: Change description of port forward rule to something else. It is not RD_Gateway. Just causes confusion.
I've installed the RD app from microsoft on my phone and I'm at work right now, it lets me connect with my phone when I use my public IP as the PC name and 192.168.0.7 as the gateway. It just doesn't work on an actual computer, despite pings to the IP working just fine. Any other way you'd suggest me doing it?

EDIT: disregard the first part, just tried and it also connects with the gateway set to "No Gateway". Still no luck on the work computer though.
 

ASK THE COMMUNITY