Question Constant FPS drops for a long period every 20 seconds on a new laptop

Jan 12, 2021
8
0
10
0
Hi I’m quite new to pc (laptop) gaming but I spent 500 pound on a laptop with ryzen 5 3500 to play rust on. At first it was running fine at about 35-40 FPS on lowest in-game settings but recently I’ve been getting these constant FPS drops every 20 seconds making the game unplayable I’ve tried every option like putting it on high performance turning off all background apps you name it, does anyone know anything that might help I just want to play games I can’t play any games without it dropping to about 7 fps.
Plz help:(
The laptop is vivo book 15 btw thanks for reading.
 
Are you playing on a server that has been running for a while? Rust server when wiped the game will run amazingly good. After a month a server is full of buildings and the fps takes a drop. Did you try on a freshly wiped server to see if your FPS is ok?
 
Jan 12, 2021
8
0
10
0
Thanks for replying fast
Are you playing on a server that has been running for a while? Rust server when wiped the game will run amazingly good. After a month a server is full of buildings and the fps takes a drop. Did you try on a freshly wiped server to see if your FPS is ok?
I haven’t checked no but it does the same on csgo aswell thanks for replying fast btw
 
Jan 12, 2021
8
0
10
0
My fan on my laptop goes really loud fast that might be a problem and overheating do you know a way I can cool it.
Plus I have msi afterburner but it doesn’t let me control the fan on there for some reason and my temp sits at around 70-80
 
Jan 12, 2021
8
0
10
0
Hi everyone, i'll try to be brief as possible.
It's been a while since i'm having FPS drops on all games that i play, even with the "lightweight" ones such as Rust and CSGO. I really don't know how to diagnose this and i need help to find the problem.

Info about the problem

Whenever i'm playing CSGO, for example, my FPS drops from 60 to 10 , playing it with the lowest configs possible and system optmizations (energy mode, system on best performance, no viruses, etc.). The drops are constant, i play for 30 seconds on 60 FPS, then it drops to 10 or so, stays like that for another 30 seconds, goes back to normal and it happens again, repeating until the match is over.
Please help me find the fix :(
Btw it was running games smooth about 3 weeks ago when i bought it
 
Jan 12, 2021
8
0
10
0
Hi everyone, i'll try to be brief as possible.
It's been a while since i'm having FPS drops on all games that i play, even with the "lightweight" ones such as Rust and CSGO. I really don't know how to diagnose this and i need help to find the problem.

Info about the problem

Whenever i'm playing CSGO, for example, my FPS drops from 60 to 10 , playing it with the lowest configs possible and system optmizations (energy mode, system on best performance, no viruses, etc.). The drops are constant, i play for 30 seconds on 60 FPS, then it drops to 10 or so, stays like that for another 30 seconds, goes back to normal and it happens again, repeating until the match is over.
Please help me find the fix :(
Btw it was running games smooth about 3 weeks ago when i bought it
 
Jan 12, 2021
8
0
10
0
Have you checked the temps?
Afterburner or HWinfo can be used for this.
Temp problems are common with laptops.
Well I have afterburner and the fan starts spinning loud and my temperature sits at about 70-75 degrees when in games but it won’t let me control the fan in msi after burner for some reason.
And it starts to drop the first 20 seconds into the game can’t even play for 20 seconds without it dropping then going back up for 30 secs then dropping again repeatedly
I’m quite new to pc gaming but it hasn’t always done this all I know it was working fine few weeks ago
 
Jan 12, 2021
8
0
10
0
what the cpu usage? malware scan the system?
is this the one only have vega 8? check the ram usage?
I will check when I get back I know i have 8gb of ram but I reseted it last night so should be clean plus it only 3 weeks since I bought the laptop
 

jay32267

Illustrious
Well I have afterburner and the fan starts spinning loud and my temperature sits at about 70-75 degrees when in games but it won’t let me control the fan in msi after burner for some reason.
And it starts to drop the first 20 seconds into the game can’t even play for 20 seconds without it dropping then going back up for 30 secs then dropping again repeatedly
I’m quite new to pc gaming but it hasn’t always done this all I know it was working fine few weeks ago
How old is it?
I might try and blow out the dust.
 

ASK THE COMMUNITY

TRENDING THREADS