Question Constant problems with Corsair USB Headset and iCUE

john3569

Distinguished
Mar 22, 2013
27
1
18,535
0
I have a Corsair Void RGB Elite USB gaming headset and I'm having nothing but problems with it. I'm not sure what triggers it, but every day something happens where YouTube videos (and all other forms of video media) will not play, and games will hang on launch. The only way to fix it is to restart my PC. Windows Audio Service will also sometimes stop responding. My PC refuses to go to sleep when the headset is plugged in, and through a 'powercfg requests' command I found out the headset was keeping it from sleeping (and audio stream is in use). I thought the problem was just iCUE, but when I'm only using my K55 corsair keyboard with iCUE I have zero issues. It is only when the USB headset is plugged in do these problems arise. I've tried the headset on my brothers PC (which has a different mobo, gpu, and RAM) and he has the exact same issues. I've done multiple clean installs of iCUE and the headset drivers themselves. Without iCUE the headset works flawlessly, but I don't have access to the virtual surround sound, EQ presets, and RGB lighting. I just don't understand why iCUE seems to mess with my system in such a drastic way. Again these problems happen everyday, sometimes more than once. Any help would be greatly appreciated.

my specs:
OS - Windows 7
CPU - Intel i53570k
GPU - Nvidia gtx680
RAM - 16 gb GDDR3
Motherboard - Gibabyte Z77X-UD3H
SSD - Samsung 860 EVO
HDD - Seagate Barracuda 2TB
 
Last edited:

Aeacus

Glorious
Ambassador
OS - Windows 7
When i was using W7, out of the blue, the exact same issue started to happen with my Corsair Void Pro RGB USB headset as well (predecessor of Void RGB Elite USB). For the love of me, i couldn't figure out why iCUE is messing up mu usage of my headset. For what i gathered, at some random point, iCUE hangs and it also hangs the W7 built-in audio drivers, where only fix is PC reboot.

Contacted Corsair support as well. Since i had my headset connected to Corsair ST100 and when i connected my headset directly to my PC, the interval of these issues plummeted. So, i bought new ST100. Sadly, some days later, the issue re-appeared and plugging headset directly to the PC only lessened the times when iCUE hanged and froze W7 built-in audio drivers as well. It was less frequent but still, not fixed completely.

After i upgraded my OS to W10, the issue went away. Somehow W10 is able to recover from the hanging of built-in audio drivers and restart it when iCUE throws it's tantrum.

Oh, my missus has the same headset as you do (Void RGB Elite USB), connected to ST100, and i have W10 on her PC as well. She hasn't reported any issues with her headset.
My best guess is that the latest versions of iCUE have compatibility issues of the obsolete W7 OS. That's why i got these issues and you are getting them right now.
 

john3569

Distinguished
Mar 22, 2013
27
1
18,535
0
Funny enough I disabled Nvidia HD Audio Driver and i haven't had those issues for roughly a week. Unfortunately my PC has randomly started freezing. The even log says Kernel Power error. The power bar and outlets around my PC were recently reconfigured and the freezing aligns with when that happened.

I think it's time I put the ole' Windows 7 down. Thanks for the suggestions guys!
 
Reactions: Aeacus

ASK THE COMMUNITY

TRENDING THREADS