Question Constant reboot new comp!! Help!

Feb 28, 2021
7
0
10
0
I just bought a PowerSpec G436 from Microcenter with the RTX3070. The comp was working perfectly for a few days and now I turn it on and it is in a constant reboot. No bios showing or anything. Powers on for a few seconds then power cycles again and again. When I use the display port OR HDMI, in the GPU it does this. If I connect the display to the motherboard display port input it boots fine. I’m wondering if the GPU may be faulty after a few days! I’m not OC or and modding. Just a stock PC a that started doing this tonight. Here are the comp specs:

https://www.microcenter.com/product/630917/powerspec-g436-gaming-computer

Any insight before I bring it back would be great.

Rob
 

Lutfij

Titan
Moderator
If you are able to get into BIOS(using the method you've mentioned above), can you check and see what BIOS version you're on at the moment? Following that, can you check and see what OS version you're on for your platform? Then check and see if you've got any yellow flagged items in Device Manager.

Specs show the PSU to be 750W but I'm curious to know what the make and model of he PSU is.
 
Feb 28, 2021
7
0
10
0
Bios: E7C98IZ1.1M1
OS: Win 10 x64
No yellow flagged items

In my bios it does say that nothing is plugged into the PCIe 16 slot where my GPU is. The GPU is getting power because it’s lit up. But the fans are not spinning.
 
Feb 28, 2021
7
0
10
0
It’s only doing the 3-5 second power up then turning off and back on for 3-5 seconds and so on when I connect the monitor to the GPU. It doesn’t do it when connecting straight to the MB
 

Infydel

Prominent
Jun 21, 2019
61
3
545
2
Gello guy's.
I'm in phase for repairing old GPU... Gigabyte GTX 1070 OC 8GB miniITX.
When PC is started, and after 10 second he rebooted. All the time.

If you have something on you'r minde for FIX, hit here.
 

ASK THE COMMUNITY