Constant stuttering in Ubisoft games with hyperthreading enabled

delboyd

Honorable
Oct 4, 2012
53
0
10,640
1
Hi,

I've been investigating this all night and it's really starting to bug me. A couple of months ago I upgraded from an FX8350 + Asrock Extreme 3 to a 4790k + Maximus VII Ranger. I have a Dark Rock 3 on the 4790k and so have clocked it up to 4.5GHz boost (no need for more, right?). It's using adaptive voltage with a + offset, which seems to be running brilliantly.

I can play Battlefield 4 at max 1440p with my GTX 970 G1 and 4790k with Hyperthreading enabled at 60fps constant. All other games work superb, fluent and smooth gameplay.

HOWEVER, as soon as I enter a Ubisoft title, it goes wrong. EVERY Ubisoft game I have stutters like crazy with hyperthreading on. ACIII, ACIV Black Flag, Far Cry 3, Far Cry Blood Dragon, Far Cry 4 and also Freedom Cry. Every 4 seconds or so the screen will lock up for around half a second and it will create these noticeable lags and freezes.

When I go into BIOS and disable hyperthreading however, the games play smooth, in fact, incredibly smooth. No stutter, no lag, just pure 60fps 1440p.

It's no good me having to disable hyperthreading permanently in order to play these games as I do a lot of Handbrake encoding for which HT really helps out. I really do feel like something is wrong but cannot find it. Can someone please reassure me my CPU isn't K-nackered?
 

Pinhedd

Polypheme
Moderator


This is pretty typical of Ubifail. Handling Hyperthreading from a thread scheduling perspective is child's play, it's truly amazing that they haven't figured this out yet. What on earth are they doing?
 

ASK THE COMMUNITY

TRENDING THREADS

Latest posts