[SOLVED] Continuous beeping even with no ram plugged in

Nov 6, 2018
3
0
10
0
My roommate recently knocked over my PC..

I have looked everywhere for an answer before finally typing my question out here.

I have an Acer x Aspire AX3-100-EF10
AMD Quad-Core A10-5700 APU w/ Radeon HD 7660D Graphics
120GB PNY SSD
12GB DDR3 memory

When I turn it on it just beeps continuously. I have removed the ram one by one and nothing changes, even after all ram is removed the continuous beeps continue. I had unplugged the 4 pin connector from the MoBo (the one connected to the PSU) and the CPU fan just spins non stop but there are no beeps and I cannot turn the computer off without unplugging it. Can someone help me? What can I do?

I also just bought a new PSU because I thought that was the problem but that was not. The new one is a Corsair CX450M. Just to throw that out there. when I unplug the 8-pin(4-pins used) from the MoBo it does the same thing. The PSU's fan spins, and the CPU fan spins non stop until I power off the PSU.
 
There's a lot that might have happened, cracking the motherboard for instance.

You could try resetting the CMOS. Remove the battery for a minute or two, then put it back in.

I'd also remove and reinstall the CPU, just to make sure it didn't get unseated. You will need to reapply thermal paste though, so don't do that until you get some.
 
There's a lot that might have happened, cracking the motherboard for instance.

You could try resetting the CMOS. Remove the battery for a minute or two, then put it back in.

I'd also remove and reinstall the CPU, just to make sure it didn't get unseated. You will need to reapply thermal paste though, so don't do that until you get some.
 
Nov 6, 2018
3
0
10
0
It didn't fall too hard so I don't think it had enough force to crack it but I could be wrong. I have tried reseating the CPU 3-4 times today alone with cleaning and re applying thermal grease.(all I got) aswell as restting the CMOS. There was only one time where I turned on the computer with only the CPU without the CPU fan and I got no beeps. but everytime after it beeps. When I remove the CPU and plug in the fan that works fine, I only get the beep when the CPU is in So I think I might need a new one but not 100% sure.
 

ASK THE COMMUNITY

TRENDING THREADS