Question Continuous blue screen deaths on login screen

Apr 5, 2019
Hi All

Wanted to get your opinion on an issue I've started to notice with my machine.

I recently upgraded basically everything but my gpu in the system and then did a new Win 10 reinstall.

New specs:
MB: MSI MEG Z390 Godlike
Ram: 16 GB (2x8), 3600 DDR4 - installed in the correct slots per MB manual.
CPU: i9 9900K
PSU: Corsair AX1000
System Storage: Samsung 970 pro 512 GB nvme SSD

The entire system is watercooled, and ambient temperatures are quite stable, even under load I have not seen any components go above 55 degrees Celsius.

After the new install the PC was working fine, so after a couple of days of just light use I started jumping into overclocking both CPU and the GPU. I started with the GPU since that's basically the only one constant in the build and had previously stable clocks on it. so i replicated the previous overclock, ran a few stress tests for a couple of hours and found it was stable enough so i moved onto the cpu

I followed MSI's guide's here for manual OC settings for i9 9900K:

I was able to achieve stable 5.0 GHZ overclocks, verified everything with stress tests for about 2 hrs. Then I decided to jump to 5.1 ghz. Initially everything worked, then the system froze during a Time Spy run in 3D Mark. After that the system could not even load windows. I reset everything in the bios, went back to base clocks, even switched the xmp off just to be sure. But I still had problems and could not start windows for hours, couldn't even get to the login screen, the PC always froze, I was able to load the installer from USB though but i had a few files i didn't want to loose already on the disc so didn't want to reformat yet and the system would not allow installing just windows as some partition was formatted NTFS instead of FAT (don't remember the exact error message). I switched it off overnight just to give it a try tomorrow, and it actually booted. Don't really know why...

But then the issue started re-appearing. Interestingly it only or mostly happens when i reboot the PC for some reason, instead of shutting it down completely. I get a variety of blue screen errors (usually they happen at the login screen before i can type in the password). I have not wrote down all of them, I think the latest one I got was "IRQL NOT LESS OR EQUAL". I checked the guides for this, and the previous ones too and most of them pointed to the same issue:

  1. Corrupt file system
  2. Hardware issues - probably RAM
  3. Hardware issues - possible MB.
My ram was still eligible for exchange so I did swap them out today, so it's a brand new 2x8 module, but the issue kept re-occurring. So that'd probably leave me with 1) or 3). I could replace the MB as well, but given it's a watercooled system, i'd prefer not to drain it again and start from zero.
I decided to actually swap out my old SSDs to a new 2TB M2 next week, so planning to do another fresh install of windows anyways, so i could eliminate 1). I've tried already scandisk, defregment. but none of them showed any issues for the disk (it's on the new Samsung Nvme, so been in use for about 10 days)

I'll try to write down all other error messages next time i run into the blue screen frenzy to give a clearer picture, but wanted to see if someone here could provide any guidance on how to eliminate the possible root cause. Currently I'm not running any overclocks on either the CPU or the GPU, only XMP is activated for the ram


IRQ errors can also be drivers - did you run LIve update 6 on the motherboard and check you have latest software? It will be on the utility page of motherboard support page

Can you follow option one on the following link - here - and then do this step below: Small memory dumps - Have Windows Create a Small Memory Dump (Minidump) on BSOD

that creates a file in c windows/minidump after the next BSOD
copy that file to documents
upload the copy from documents to a file sharing web site, and share the link here and I will get someone to convert file into a format I can read
Apr 5, 2019

So I had a pretty interesting morning with the PC.

I updated all drives and the BIOS to the latest version. TL&DR after this I had quite a bit of rollecoaster ride...

  1. After all the updates, rebooted. again BSOD with "PAGE FAULT IN NONPAGED AREA" error message.
  2. Automatic repair came -> choose to continue and system set up afterwards.
  3. Had to do a random reboot.
  4. Again BSOD with same error "PAGE FAULT..."
  5. Autorepair and BSOD while autorepair loading with the same message.
- This has happened 3 times in a row, so I shut down the PC completely, and kept it off for a few minutes (disconnected power cord)

  1. Again booting into repair this time BSOD with USBSTOR.SYS - realized the USB stick I used for BIOS update was still plugged in, so removed it.
  2. repair mode again --> diagnosing pc --> no results
  3. Plugged in a bootable win10 USB for system reinstall (since at this stage I could not even get to the login screen of windows) Formatted the system drive, then "Windows could not prepare the computer to boot into next phase of installation", shut down the PC after this.
  4. Removed all extra PCI express cards (USB 3 & sata extension) + disconnected all other drivers, so now only the M.2 drive is available. Only keyboard / mouse plugged in.
  5. Disabled XMP in BIOS, and also removed the stage 2 automatic overclock in the MSI BIOS that kept the CPU at 4.9 GHZ (there is both a hardware and BIOS switch for this OC, only the BIOS version was enabled, but removed it now so it's back to stock compeltly).
  6. Formatted system drive again, was able to install windows 10 without issues and produced a clean startup and booted into desktop.
  7. Rebooted, entered BIOS and enabled XMP and Switched CPU overclock back to stage 2, 4.9 GHX
  9. Rebooted, entered BIOS, resetted OC to zero, XMP is still on
  10. Booted without issues into Windows
  11. Rebooted a few times without issues. System seems to be stable for the past couple of hours.
Based on the above, I am more and more certain it's not a windows issue after all. The only other weird software issue i recognize is that my Google chrome tabs are keep crashing, especially gmail and some newsites +

Contacted MSI technical support with the issue as well, as this seems to be happening when i am enabling the CPU overclocks. Not sure whether it is a CPU or a Motherboard issue at this stage. Power can't be a problem given the AX1000 PSU, not drawing even half of it from the wall.
As mentioned the ram is brand new, arrived yesterday afternoon, so hopefully it's not the faulty. Games, benchmarks...etc everything runs stable at base clocks now but the goal of this motherboard + cpu combo is overclocking them so hoping I can figure this out.
Everything is less than 2 weeks old from amazon so can return / replace them but would love to avoid taking a custom waterloop apart again.

Is there a way I could narrow down what might be the issue ? At this stage I believe it can be only these 3:
  1. Motherboard
  2. Super unlucky silicon lottery with the CPU
  3. Issue with the M.2 SSD (this i think is the least likely ?)
Thanks for any feedback / help - very much appreciated.


1. hard to check motherboards, best bet is check everything else first and reduce the possible causes that way. Process of elimination.

2. Can run this on it -

could also run this on ram - memtesst86 , one stick at a time, up to 8 passes. Only error count you want is 0, any higher could be cause of the BSOD. Remove/replace ram sticks with errors.

Unlikely to be ram though if its same error code as before the new ones. Is ram on motherboard compatibility chart?

Memtest can also be used to check the different slots on motherboard work as well. If both sticks work fine, run a test with both sticks in can check if it is perhaps the 2nd slot on motherboard that is cause. It is just a test, I am not suggesting it is.

3. I would be surprised if its m.2, you can run Samsung Magician on it and check its SMART score and see if any new firmware.
Last edited:
Apr 5, 2019
  1. Ran the CPU Test, didn't produce any errors, it passed the test (though it's not overclocked right now).
  2. ran the Samsung test as well on the SSD, no results.
Will do the memory test tomorrow.

Thank you for the tips