cookies serverside? (done in new s/w released)

dhlucke

Polypheme
Steve, it's really difficult with the way cookies are setup now. Two things are happening. First, since I use the forum from home and work there is no consistancy and I have to sort through everything twice. Second, if I log out or my cookies get deleted everything resets again.

How much trouble is it to keep track of everthing serverside?
 

steve_sa

Distinguished
Nov 6, 2005
662
0
18,980
It is difficult, but I will think about ways that it can be done. The base s/w does not work as you state (altough I understand your requirements). This is not going to happen immediately, but I will try to figure out a solution. Patience.
 

pickxx

Distinguished
Apr 20, 2004
3,262
0
20,780
Maybe this is the same thing....but if i refrsh the community pages it refreshes the whole forum.

meaning if i am chatting in the other and i refresh a couple times to post there and see what threads are active....
When i go to hardware...there are NO new posts because all the refreshing from the "community" has overlapped into "hardware"

I think you should understand what i mean but i dont know....Its a pain to refresh a couple times in the other and then go to hardware and none of the posts have the "new post" symbol and yet i know there are new ones...i end up rereading a lof of stuff because i can't tell what is new and what isnt
 

pickxx

Distinguished
Apr 20, 2004
3,262
0
20,780
if i get home from work....check the other...reply to a couple things...refresh....then head to hardware...a lot of times i dont see new threads.
 

jiffy

Distinguished
Oct 2, 2001
1,951
0
19,780
That would be a pain Dh.

I notice something similar to what Pickxx said. One minute there were a lot of new post and then they were all gone and I didn’t open any of them. It seems to work OK now.

I had another problem. I wasn’t able to quote when I had cookies/ad blocker on medium in ZA, but its working fine now
 

steve_sa

Distinguished
Nov 6, 2005
662
0
18,980
Maybe this is the same thing....but if i refrsh the community pages it refreshes the whole forum.

I cannot replicate that pickxx. What link did you click on to refresh the community pages, pls post the url here.
 

pickxx

Distinguished
Apr 20, 2004
3,262
0
20,780
perfect example.....I have never been in the CE forum before...i clicked on it and it said none of those threads are new to me....none
I have never been into the software section....and i know if i clicked on it...none of those would be new.

If everything is going tobe segrgated like this, shouldn't each section update as you enter that section?

if i am in the other for a couple hours without closing my browser, the hardware section will only say i have like 1-2 new threads....even though i know i have 200. its just that those 1-2 happened since my last refresh while i was in the other.


how i refresh....if i have the other forum open, i move my mouse over the icon on my browser that says 'Refresh" and i click it. Then it reloads the page and will update me with an orange graphic if a topic has been posted in since i last was in that thread/left and then came back to the forumz
 

steve_sa

Distinguished
Nov 6, 2005
662
0
18,980
pickxx,

I will look into it. Thanks.

I believe the logic is 'show me new posts since last visit' which explains it all, but I have to look into it to be sure that is how the logic is setup in the s/w.

Scuba Steve (your copyright)
 

dhlucke

Polypheme
Hey steve, can I request that this be at the top of the features list? The way it is now is fine, maybe, on one computer, but on more than one computer it is very difficult.
 

steve_sa

Distinguished
Nov 6, 2005
662
0
18,980
It is already done with the new release.

The way it works is that now the last visit time is saved to user table, and not cookied. So if you go to another computer, it remembers last visit.

The orange/white status relate to posts since last visit, so status info does not need to be saved server side, since everything resets to 'last visit'.