Question Corrupt system32 driver

Denziok

Commendable
May 28, 2017
3
0
1,510
0
Hi all,


I have a big problem which I would like to have solved.
I recently, at the time of writing two days ago, wanted to download the English (US) language package for Win10 from the settings app. After it was done installing it asked me to sign-out of my account. So I did just that, however, when I wanted to sign back into Windows it didn’t recognized my pin-code and password.

Something in the likes of “Couldn’t get a reference” or something, can’t remember exactly. So I thought, let’s restart this again. When I was about to do that, it said “Update and shut down”. Nothing wrong with that, I thought, but after that more problems arouse.

The update was really quick, maybe he didn’t update at all because it was a quick flash and then a black screen. I turned my computer back on but instead of just booting up normally, a blue screen appeared with “Your computer didn’t boot up correctly’’ and it got me in the startup settings where I got nine options with the likes of “Boot up in safe mode”, “Start Windows recovery mode” etc. I tried all of them but nothing worked.
I hooked on my old hard drive, which I used as my boot drive before this drive, and when I started my PC it said “It looks like Windows didn’t load correctly’’. This is Windows Recovery mode, which I didn’t know existed before this. I tried every option within the advanced options section from ‘’system repair’’ to ‘’startup repair’’ and ‘’go back to a previous version’’ etc.

I even tried formatting the drive (a SSD btw) via the command prompt window. But this wasn’t successful because it said you can’t format a drive which has Windows 10 installed on it.
When I did a system repair scan it said it could repair anything but there was a file missing/corrupt or something else. This is the acpi.sys driver in the System32 folder. After some searches on Google it came to my attention that more people had this problem after rebooting their computers with almost always a corrupted file as a cause.

Most of these people could replace this file by copying it from another PC or from someone who had uploaded it. The problem is, I can’t get into Windows with my other hard drive while my SSD is connected, this way I can’t go and replace the file. But this also doesn’t give me the assurance that it is indeed the acpi.sys file that’s causing all this trouble. I can boot into Windows when I only have my old hard drive connected though, no problems there.
I’m pretty desperate and was already thinking to send back my SSD for a new one.
Is there someone who can help me?

Thank you in advance!

[mod edit - spacing]
 
Last edited by a moderator:

Colif

Win 10 Master
Moderator
20 lines without a break? I added a few, people might read it now :)

it seems strange it asked you to sign out just after install.

fast update - there was a super fast one recently, all it does is apparently change the version of win 10 from 1903 to 1909. It took 2 minutes to install here.

Have you confirmed your login info is right? if its a microsoft Account, you can login here - https://account.microsoft.com/account

If your account works, why not clean install win 10 on ssd again?

You shouldn't be missing files on a brand new install.
 

Colif

Win 10 Master
Moderator
Better off with a New ISO on a fresh USB and start again, shouldn't have corrupt files on a new install

if problem persists, Try running memtest86 on each of your ram sticks, one stick at a time, up to 4 passes. Only error count you want is 0, any higher could be cause of the errors. Remove/replace ram sticks with errors.
 

ASK THE COMMUNITY

TRENDING THREADS