Question Corsair avoid pro wired headset mic not working

Jun 1, 2020
6
0
10
0
I need help with my headset. I’m not rich or well off. Actually a single mom going through a rough patch with employment. So I can’t afford a high end headset and have to make due with what I have. I’m kind of new to this stuff, and really need some help. My father referred me to you guys telling me if anyone could help, it would be this place. So here’s my problem.

I bought a Corsair void pro headset a month or two back. The wired one. Not the USB one. Relatively cheap. And it would work for what I needed it for. Got home. Unboxed. It didn’t work. Sent it back, and just got the replacement one from Corsair. The sound works on this one quite well. But I can’t get the mic to work. Well. Kind of.

If I put the mic right to my mouth and speak, it picks up my voice. If I tap the mic, it picks the sound up. If I play a video on Youtube while in discord, it picks up the sound and plays it on his end. But having the mic at regular distance from my mouth, it does not pick up voice at all. As I’m on discord with my father, the mic test shows it’s picking up his voice on the other side. But not mine. If I’m in game, with discord up, my father can hear the game sounds. I’ve played around with settings, put in tickets, and everything else. But I can’t fix it. I’ve tried upping my sensitivity as well and that hasn’t worked. Plugged the headset into different panels, that hasn’t work. I just really need some help.


New update: Even with my mic muted, game sounds can be heard on and off through discord on my father's end.

Thanks in advance.
 
Last edited:
Jun 1, 2020
6
0
10
0
1) Open Control Panel > Sound > Recording

2) Click "Headset Microphone" > Corsair VOID PRO

3) Advanced > Default Format
For on
What frequency are your mic settings at? Out of the box they set the frequency to 8000hz, it should be 48000hz.
First, it just shows as "microphone", not as Corsair VOID PRO, and underneath it says Realtek High Definition Audio. But, the frequency is set to "2 channel, 16 bit, 48000 Hz (DvD quality)"
 
Jun 1, 2020
6
0
10
0
Is it a 3.5mm jack or USB connector to plug it into your computer? If it is USB I would suggest you download the Corsair iCUE software https://www.corsair.com/us/en/icue

If you dont want to do that or it doesnt help the next step would be

Windows Sound Control Panel->Recording->Corsair Headset->the adjust levels to max and in Advanced change it to 16bit 48000hz
Replied to someone else below. It is set to that. It's 3.5mm. I've changed the places they plug into several times, with no change in results.
 
Jun 1, 2020
6
0
10
0
What kind of computer are you using?

Is the headeset a single or dual 3.5mm jack?
It's a wire void pro headset, with a little 3.55mm attachment that has 2 split jacks. One for headset, one for mic. Plugged them both in to different slots, correctly, and it didn't change anything. Tried different slots. Didn't work. I have one of the CyberPower PC from best buy. One of the gaming desktops.
 

ASK THE COMMUNITY

TRENDING THREADS