Question Corsair AX1200i Fails self-test when plugged in

Jan 8, 2020
3
0
10
0
Hello all!

Recently my PC stopped turning on.

I was able to narrow it down to my PSU not working properly because the self-test failed. The self-test button only caused a click sound and nothing else, no green light, and no fan spin. I removed the PSU, did the self test with nothing plugged in except the power cord and I got the green light and fan spin.

I think it might be a cable shorting itself.

I tried the self test with my motherboard cable, CPU cable, and GPU cables only, failed. I tried with just the motherboard cable, failed. I tried it with a known good cable (PC was running right before the test on my PSU and still running after the test) and it still failed.

I'm thinking it's an internal short circuit or something with the motherboard cables, but I have no idea how to fix it.

Any thoughts?
 

Phaaze88

Dignified
Herald
RMA it then.

After Googling this unit, I've found that this is a common issue with these particular models.
I can't imagine if it's a fault with the device, or perhaps faults within the user's electrical wiring is somehow tripping the fail safes.
 

jonnyguru

Distinguished
Hello all!

Recently my PC stopped turning on.

I was able to narrow it down to my PSU not working properly because the self-test failed. The self-test button only caused a click sound and nothing else, no green light, and no fan spin. I removed the PSU, did the self test with nothing plugged in except the power cord and I got the green light and fan spin.

I think it might be a cable shorting itself.

I tried the self test with my motherboard cable, CPU cable, and GPU cables only, failed. I tried with just the motherboard cable, failed. I tried it with a known good cable (PC was running right before the test on my PSU and still running after the test) and it still failed.

I'm thinking it's an internal short circuit or something with the motherboard cables, but I have no idea how to fix it.

Any thoughts?
You can't have the 24-pin connected when trying to perform the self-test. Says so right in the manual.
 

ASK THE COMMUNITY

TRENDING THREADS