Question Corsair AX1200i shuts off then shows a red light. Do I need to buy a new PSU?

SkinnyWalrus

Reputable
Jun 25, 2016
6
0
4,510
0
Hello, I've had my ax1200i for 3 years now, it's been working great until a few days ago. After I use my computer for a bit my PC shuts off then my PSU shows a red light. I hold the power button on my computer to completelty shut it off, I then try to turn it back on, but it only turns on for a second then my PSU immediately goes to a red light. Once again I turn it off completely, I let my PC sit off for a few minutes, then when I power it back on my PSU works normally showing a greenlight, but after a while of using it my PSU goes back to red. I'm not really good with computers, so if I had to take it apart completely to troubleshoot I would be lost.
 

helpstar

Illustrious
Did you try the self test freature?
"In order to use the self-test feature, please follow the steps below. 1. Connect the PSU to an AC power source, and flip the power indicator on the back of the PSU to the On position (I). 2. Press the self-test button on the modular connector side of the PSU. 3. If the button lights up green and the fan spins for a moment, you’re good to go! 4. If the button lights up red or does not light up at all, please contact Corsair customer service for further technical support. " source: corsair

What other hardware are you using?

Were the original Corsair cables used with this PSU?

This PSU has 10 years of warranty, if you wanna RMA it
 
Last edited:

ASK THE COMMUNITY

TRENDING THREADS