Question Corsair CV550 or Cooler Master MWE V2 550w

autoblogart

Reputable
Apr 18, 2018
217
0
4,590
1
Guys i recently want to buy a new psu and i only have 2 options Corsair cv550 or cooler master mwe v2 550

I dont know whats better and whats stable and safe ?

Im going to run the psu in this specs :

I5 2500k no overclocked
8gb ram DDR3
Gtx 650 1gb

What should i get in your opinion
Thank you
 

keith12

Illustrious
Hey there,

TBH they are roughly about the same level. For your system type (an older system) they should do just fine for your needs. They are not the best PSU's out there, but not terrible either.

In this case, whichever one is the cheapest.
 

autoblogart

Reputable
Apr 18, 2018
217
0
4,590
1
Hey there,

TBH they are roughly about the same level. For your system type (an older system) they should do just fine for your needs. They are not the best PSU's out there, but not terrible either.

In this case, whichever one is the cheapest.
Which one is more stable and safer im thinking about corsair is it good ? I did read bad reviews about the cm v2
 

awayagain

Reputable
Jun 27, 2018
76
5
4,545
2
both are good psu for 550w
but look also at warrenty Cooler master offer 5 year against 3 corsair
warrenty year is also a good way to look at by wich component is used in it
so go for the cooler master since it"s their V2 model
 

autoblogart

Reputable
Apr 18, 2018
217
0
4,590
1
They are both on par with each other. I don't think either has an advantage over the other. Ideally I would recommend a Corsair CX as a budget psu.
Unfortunately the CX is not available in my area and I couldn' find it , I got a Corsair CV550 and came home i did face 1 problem and I want to ask :

1) The CPU ATX in my motherboard is 4 pin but in the PSU that I got its 8 pin I did google and found that it's a 4+4 and then I did split cables and plugged the 4 pin and is that okey ?

2) second thing to mention here is that my PC was not turning before, no display no beep nothing so I changed psu and ram, CPU is working and all other things , could it be the motherboard that's causing the problem guys ?

Note : when I installed psu and forgot to plug the 4 pin ATX CPU cable it did turn on but fans at max and no display when I tried after searching google and plugged the 4 pin to ATX CPU in motherboard I tried again , no life at all no beep no display nothing ,

I had the same issue before with the old psu , and I even tested old psu in another PC and psu worked and other PC worked as usual

3) So is the problem from my motherboard ?

I hope you answer all the questions and thanks again :)
 
Last edited:

ASK THE COMMUNITY