Question Corsair H100i Elite Capellix giving "pump failure" and "cpu fan error" on Asus x470 f gaming motherboard

Ima OpGamer

Honorable
Apr 29, 2016
24
0
10,510
0
Hi all, this is really frustrating me now because I want to like this AIO but it just doesn't want to work.

I got it earlier today, installed it following every single step of the instruction as it said and after booting it up I saw it said "cpu fan error". So I powered it off and I tried switching the pin header from cpu fan which it said on the manual to aio pump instead and it still fetched me the same result after booting.

At this point I went online to try and find a solution and one thing I realised was that every other person that had this issue/similar issue all were using Asus motherboards... Anyways I saw that I could ignore the cpu fan in bios which I did and that allowed me to boot into desktop.

Then the next problem came, everytime I turned it on the fans would light up the normal RGB for a few seconds before turning red and flashing as well as the fans being on max speed and in ICUE it was giving me a "pump failure" notification even though the cpu temps was proving otherwise at 26°c. I turned it off, switched the AIO header back and forth between cpu fan, aio pump, water pump and all to no avail.

The cooler is working but it doesn't want to accept the fact that it's working and I have no idea why. The pump is clearly working but it's not picking up the pump speed on ICUE.

Sorry for the long read, that is my current situation and if anyone knows a solution I can try that would be great.

Specs:
Ryzen 5 2600
Asus Strix X470-F Gaming
Corsair H100i Elite Capellix
Gigabyte GTX 1070 G1 Gaming

Demonstration - View: https://imgur.com/a/GJTJWms
 
Last edited:

COLGeek

Cybernaut
Moderator
Just sharing. A very recent thread with a very similar issue.

 

Ima OpGamer

Honorable
Apr 29, 2016
24
0
10,510
0
Just sharing. A very recent thread with a very similar issue.

I saw that and tried to switch the type3 sata cables but it still wasn't working unfortunately.
 

Ima OpGamer

Honorable
Apr 29, 2016
24
0
10,510
0
In your BIOS, do you have any fan settings that you changed (vice standard default settings)?
Haven't changed anything to do with the fans at all other than just setting the "cpu fan speed" to ignore so that it doesnt give me the cpu fan error on boot and not allowing me to go into desktop.
 

Ima OpGamer

Honorable
Apr 29, 2016
24
0
10,510
0
Can you post a picture of the inside of your rig, showing how your AIO is connected? Use a site like imgur.com and then place a link here.

Also, is your motherboard BIOS and iCUE both fully up to date?

Are you using the Commander Core as well?

https://help.corsair.com/hc/en-us/articles/360025278572-Update-device-firmware-with-iCUE
Motherboard and ICUE are both fully up to date and yes commander core is in there. Hard to see cables inside so I drew the arrows.
View: https://imgur.com/a/GJTJWms
 

COLGeek

Cybernaut
Moderator
Double check that you have the connector for the CPU_FAN on the right end of the header. The tab should help ensure a proper connection.

If apparently connected properly, look at the connector to see if the female end of the connector is making contact with the male pin on the motherboard header (this might be difficult to see).
 

Ima OpGamer

Honorable
Apr 29, 2016
24
0
10,510
0
Double check that you have the connector for the CPU_FAN on the right end of the header. The tab should help ensure a proper connection.

If apparently connected properly, look at the connector to see if the female end of the connector is making contact with the male pin on the motherboard header (this might be difficult to see).
Yup can confirm that it is connected properly, it only goes in one way and is seated correctly, unfortunately still not solved. I think maybe it's something to do with the pump's rpm sensor not working? Maybe that's where the "pump failure" message is coming from and because the sensor isn't working it thinks it's broken which it isn't, the temps are normal.
 

ASK THE COMMUNITY