Question Corsair HS60 Pro Error Code 43

Sep 21, 2020
Hi all,

So I recently purchased a Corsair HS60 Pro headset, and it's been working okay. I had the iCue software installed, and drivers were up to date and such. It has a 3.5mm, but also came with a USB adaptor that lets me make use of its surround sound, which is how I've been using it.

I had a few times were, while watching YouTube or gaming, the headset (both audio and mic) would cut out randomly. Simply unplugging and replugging the USB would make it work again. However, today it happened again, and no amount of unplugging, restarts or anything that I can think of is working.

The headset itself is working if I use the 3.5mm connector, but with USB, nothing. I even tried on a laptop, and got the "Device Malfunctioned" popup on my screen.

Back on the device manager on my PC, it shows up as "Unknown USB Device (Invalid Configuration Descriptor)". It isn't showing up in iCue.

I'm not much of a tech wiz, so I can't exactly decipher what exactly the device manager logs are saying, but under the Events tab, there are two: "Device configured (usb.inf)" and "Device not started"

I'm not exactly sure that this is a problem with my headset, as my previous headset (Xiberia T19) had the same problem, but it was solved by replugging it a few times, though I ended up replacing it to get rid of that inconvenience. It had no issues for about a year, but only developed that issue a couple of weeks ago.

Is there any way to fix this? I can't think of anything