Question Corsair RM650 2019 softly clicks when computer turns on

Aug 16, 2020
6
1
15
0
The title; should I be worried or just ignore it? Has it happened to anyone before? I've had it for a few days now. No other problems than that. Thanks
 

Vic 40

Titan
Ambassador
Ah, thanks. My previous PSU blew up (TX650M) and I really didn't want a problem with the new one.
Hope you rma'd? And if not why not?! Unless being able to change it for the RM ...

There could be problems with psu's from a certain time period (batch codes) from Corsair. Can look the code up,

https://forum.corsair.com/v3/attachment.php?attachmentid=38200&stc=1&d=1590785050


if between codes 194448xx to 201148xx might it be the problem they had and would rma be the way to go. This was first solely for the SF series, but have seen jonnyguru mention this with other models like the TXM as well.
 
Aug 16, 2020
6
1
15
0
Hope you rma'd? And if not why not?! Unless being able to change it for the RM ...

There could be problems with psu's from a certain time period (batch codes) from Corsair. Can look the code up,

https://forum.corsair.com/v3/attachment.php?attachmentid=38200&stc=1&d=1590785050


if between codes 194448xx to 201148xx might it be the problem they had and would rma be the way to go. This was first solely for the SF series, but have seen jonnyguru mention this with other models like the TXM as well.
Yeah, I did RMA the old PSU, but as the process took 4 weeks I bought a new one and am now planning on selling the TXM if all things work out.
 
Reactions: Vic 40

ASK THE COMMUNITY

TRENDING THREADS