Question Corsair Vengance 1600Mhz 1.5v 9-9-9-24 Broke my Memory Controller?

chrisheavymetal

Distinguished
Feb 3, 2010
4
0
18,510
0
To clear things up I had the following Memory and wanted to upgrade my RAM from 8GB to 16GB..

1) Corsair Vengance (1x4GB) 1600Mhz 9-9-9-24 1.5v (I had 2 of those sticks)

2) Corsair Vengance (3x4GB) 1600Mhz 9-9-9-24 1.5v (Got 2 of these from friend)

3) The only difference on my 2 modules was the version numbers. Mine was version 5.12 and his was version 8.10 or something like that. (I could not find anything else like this on Internet.)

I could not make these work and my PC did not boot so I took my PC to the same friend that had these extra ram modules he got it to display and run 16GB but not for long played CSGO for about 10min and my PC locked up and shutdown.

Can it be possible that he blew my Memory Controller on my motherboard?
As my motherboard does not work at all anymore.
 
To clear things up I had the following Memory and wanted to upgrade my RAM from 8GB to 16GB..

1) Corsair Vengance (1x4GB) 1600Mhz 9-9-9-24 1.5v (I had 2 of those sticks)

2) Corsair Vengance (3x4GB) 1600Mhz 9-9-9-24 1.5v (Got 2 of these from friend)

3) The only difference on my 2 modules was the version numbers. Mine was version 5.12 and his was version 8.10 or something like that. (I could not find anything else like this on Internet.)

I could not make these work and my PC did not boot so I took my PC to the same friend that had these extra ram modules he got it to display and run 16GB but not for long played CSGO for about 10min and my PC locked up and shutdown.

Can it be possible that he blew my Memory Controller on my motherboard?
As my motherboard does not work at all anymore.
Nope.
 

chrisheavymetal

Distinguished
Feb 3, 2010
4
0
18,510
0
I am no tech guru but I know most of the Basics, all I know I had my memory in Dimm 1 and dimm 3 which is the correct way of running dual channel as they are marked blue on my motherboard, as soon as i inserted his memory in dimm 2 and dimm 4 the pc would turn on no display and my gpu fans would ref up to 100%. And I was sceptic about the versions on the Modules and took it out and the next day took it to him he put it in like this also did a cmos reset before he started put in one by one turning pc off each time adding the next module you get it but it ended up being dimm1 one of his dimm 2 one of mine dimm3 one of his and dimm 4 one of mine and it worked, For 10 minutes. After that 3 beeps does not matter what he did after.
 
Last edited:

ASK THE COMMUNITY