Question Corsair Vengeance RGB PRO 16GB doesn't work with MSI b450 Tomahawk Max

adamekcerv

Prominent
Dec 23, 2019
8
0
510
0
Hi,
My motherboard (Tomahawk Max) doesn't work with Corsair Vengeance RGB PRO 16GB. There is no screen/display on boot. It worked without problem for a few months a after that the RGB turned red and I wasn't able to boot my PC. When I change the RAM to Corsair 16GB KIT DDR4 3000MHz CL16 it works. And the Vengeance RGB PRO also works with a different MOBO. Where is the problem ?
Thank you very much.
 

RealBeast

Titan
Moderator
Hi,
My motherboard (Tomahawk Max) doesn't work with Corsair Vengeance RGB PRO 16GB. There is no screen/display on boot. It worked without problem for a few months a after that the RGB turned red and I wasn't able to boot my PC. When I change the RAM to Corsair 16GB KIT DDR4 3000MHz CL16 it works. And the Vengeance RGB PRO also works with a different MOBO. Where is the problem ?
Thank you very much.
Most likely the memory is not on the QVL for your motherboard because Ryzen CPUs don't work well with some memory, you need the Corsair Vengeance RGB PRO 16GB for AMD. You can check on compatible memory HERE.

It is often possible to get that memory to run at 2133MHz and loose timings. Contact Corsair support HERE, and they may offer you an exchange or settings to use.
 

adamekcerv

Prominent
Dec 23, 2019
8
0
510
0
Most likely the memory is not on the QVL for your motherboard because Ryzen CPUs don't work well with some memory, you need the Corsair Vengeance RGB PRO 16GB for AMD. You can check on compatible memory HERE.

It is often possible to get that memory to run at 2133MHz and loose timings. Contact Corsair support HERE, and they may offer you an exchange or settings to use.
Interesting is, that it worked without any problem for at least 4 months.
 

RealBeast

Titan
Moderator
It can run but may not, which is the issue. If it is on the QVL and fails you can RMA it.

Search through the memory threads and you will find dozens, as this is a very common issue for the B450 and lower motherboard models running the newer Ryzen CPUs.
 

punkncat

Honorable
Ambassador
I was unclear if you said you were or were not on a newer BIOS and/or experienced that issue after a change.

The other aspect is the RAM RGB going "just red". Is this indicative of a failure of the RAM? When it is operating fine in the other motherboard is the RGB behaving normally?
 

ASK THE COMMUNITY