Question Corsair Void RGB Elite Wireless - Mic doesn't work

Barty1884

Titan
Moderator
Hi all,

So, for Xmas, the Mrs got me these.

However, when I finally got around to trying to use them earlier today, the mic just doesn't work. Hoping I'm missing something obvious, but I suspect they're defective.

Charged them, connected the USB receiver - fired up the system.
I'm not a fan of additional software etc, so didn't start with iCue initially. I just let Windows handle driver install, and the audio aspect just worked.

I noticed the mic was detected in Windows, but no testing (in Windows, Steam nor Discord) would successfully register any input.

So, I gave up, and installed iCue. However, even then, while I now get the verbal feedback, all I can get is "Headset on, Charging, Mic off.

Mic is in the 'down' position, so shouldn't be muted via the hardware level toggle (lift to mute) - but the button on the earcup to mute/unmute doesn't do anything, and the LED on the mic itself remains illuminated, signalling the mic is muted.

Within iCue, the mic shows as muted (greyed out) and will not let me toggle to 'on' (which is yellow).
However - when I hold the power button on the headset, it turns off - but at that stage, the mic within iCue is then enabled/yellow.

While it doesn't make much sense logically, a basic observation is that the mic is somehow reversed.
Headset on = Mic muted
Headset off = Mic unmuted.

Followed results of some quick Google searches, but no dice.
I've made sure there's no privacy limitation within Windows ,... I've removed all traces of iCue, disconnected the headset, rebooted, reinstalled iCue before reconnecting the headset and still no success.

Am I missing something obvious? Or is it more likely that I've got a defective unit?


EDIT Just tried on another system - exactly the same results.

Heatset powered on, iCue mic control greyed out and physical button on the headset does nothing.:


Heatset powered off (as denoted by the warning triangle), the mic can suddenly be unmuted and volume adjusted but doesn't change what happens when the headset is powered back on.



Once it's back on, it's greyed out in iCue, physical button doesn't do anything - and the "muted" LED is on.
 
Last edited:
Jan 14, 2020
1
0
10
0
I have had the headset for 2 years now. Had an issue now where my mic shows that it is unmuted but nothing is being picked up on the mic. Did the same as you and got nothing. I installed the unit on my other machine and now I have the same muting issue as you. Tried rolling back to an older version of iCUE,but that didn't solve it. Seems it is a conflict between Windows and the drivers :/
 

Barty1884

Titan
Moderator
In the end, I reached out to Corsair, explained the issue (almost like the mic was reversed... on when headset off, off when on) and they suggested a return or RMA.

Exchanged via Amazon, and everything works as intended now.
 

ASK THE COMMUNITY

TRENDING THREADS